











	
	
	
	
	
	
		
	
	
	
	
	
	
	


<!DOCTYPE html>
<html lang="en-AU" xmlns:og="http://ogp.me/ns/fb#"  xmlns:fb="http://www.facebook.com/2008/fbml" class="au">

	<head>
		<!--  -->

		
			
		

		
		<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<meta charset="utf-8">



	<title>Arrow&#39;s Mystery Deepens With Katherine McNamara&#39;s Arrival &amp; Huge Green Arrow Twist | E! News Australia</title>
	<meta name="description" content="So much just happened and we can&#39;t even deal with it">

	
	
		<link rel="alternate" href="https://www.eonline.com/news/992882/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="x-default" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/news/992882/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-us" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/news/992882/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/au/news/992885/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-au" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/uk/news/992884/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-gb" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ca/news/992883/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-ca" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-bd" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-bt" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-bn" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-kh" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-cn" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-tl" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-fj" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-hk" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-jp" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-kr" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-in" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-id" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-la" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-my" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-mv" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-mo" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-mn" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-mm" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-np" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-pw" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-pg" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-ph" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-sg" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-lk" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-tw" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-th" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-vu" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/992886/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" hreflang="en-vn" class="js-onee-hreflang">
	
	
	<meta name="one.e.enabled" data-edition="au" class="js-onee-meta-tag">
	
	
	<link rel="shortcut icon" href="/resources/images/misc/favicon.ico">
	<link rel="icon" href="/resources/images/misc/eonline_favicon_trans.png">
	<link rel="apple-touch-icon" href="/apple-touch-icon.png">
	
	
	<meta name="google-site-verification" content="PrhEi7w612RQMIMh7TQkkEOxkApb2TCbAZBdqITWU3U"> 
	<meta name="msvalidate.01" content="564B986CE3CECCAE84779191BEC6B755"> 
	
	
	
<meta property="og:title" content="Arrow&#39;s Mystery Deepens With Katherine McNamara&#39;s Arrival &amp; Huge Green Arrow Twist">
<meta property="og:type" content="article">
<meta property="og:url" content="https://www.eonline.com/au/news/992885/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist">
<meta property="og:image" content="https://akns-images.eonline.com/eol_images/Entire_Site/2018113/rs_600x600-181203175130-600x600.arrow-stephen-amell-emily-bett-rickards-lp.12318.jpg?fit=around|600:467&crop=600:467;center,top&output-quality=90">
<meta property="og:site_name" content="E! News">
<meta property="og:description" content="So much just happened and we can&#39;t even deal with it">
<meta property="og:locale" content="en_AU">




	<meta property="og:image:width" content="600">
	<meta property="og:image:height" content="467">
	<meta property="article:published_time" content="Mon Dec 03 18:00:00 PST 2018">
	<meta property="article:modified_time" content="Mon Dec 03 18:01:04 PST 2018">



	


<meta property="fb:admins" content="10101649">
<meta property="fb:pages" content="89033370735">
<meta property="fb:pages" content="199268073449270">
<meta property="fb:pages" content="1387539234854280">

	<meta property="fb:app_id" content="195662528604">




	<meta name="twitter:card" content="summary_large_image">
	<meta name="twitter:site" content="https://twitter.com/eonlineAU">
	<meta name="twitter:title" content="Arrow's Mystery Deepens With Katherine McNamara's Arrival">
	<meta name="twitter:description" content="So much just happened and we can't even deal with it">
	<meta name="twitter:image" content="https://akns-images.eonline.com/eol_images/Entire_Site/2018113/rs_600x600-181203175130-600x600.arrow-stephen-amell-emily-bett-rickards-lp.12318.jpg?fit=around|600:300&crop=600:300;center,top&output-quality=90">
	<meta name="twitter:url" content="https://www.eonline.com/au/news/992885/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist">


	





	
	<meta class="swiftype" name="category" data-type="enum" content="News">
	<meta class="swiftype" name="publication_date" data-type="date" content="2018-12-03T18:00:00 PST">
	<meta class="swiftype" name="title" data-type="string" content="Arrow's Mystery Deepens With Katherine McNamara's Arrival & Huge Green Arrow Twist">
	<meta class="swiftype" name="image" data-type="enum" content="https://akns-images.eonline.com/eol_images/Entire_Site/2018113/rs_600x600-181203175130-600x600.arrow-stephen-amell-emily-bett-rickards-lp.12318.jpg">
	
		<meta class="swiftype" name="tag" data-type="string" content="Arrow">
	
		<meta class="swiftype" name="tag" data-type="string" content="TV">
	
		<meta class="swiftype" name="tag" data-type="string" content="Top Stories">
	
		<meta class="swiftype" name="tag" data-type="string" content="Entertainment">
	
		<meta class="swiftype" name="tag" data-type="string" content="Apple News">
	


	



	<meta name="sailthru.contenttype" content="news">
	<meta name="sailthru.image.full" content="https://akns-images.eonline.com/eol_images/Entire_Site/2018113/rs_600x600-181203175130-600x600.arrow-stephen-amell-emily-bett-rickards-lp.12318.jpg?fit=around|300:300&crop=300:300;center,top&output-quality=90">



	<meta name="sailthru.cid" content="992885">



	<meta name="sailthru.ed.cid" content="au_992885">


	
	
	
		<link rel="canonical" href="https://www.eonline.com/au/news/992885/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist">
	

	
		
		
	

	
		
		
	

	
		<link rel="alternate" media="only screen and (max-width: 640px)" href="https://m.eonline.com/au/news/992885/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist">
	

	
	
		<link rel="amphtml" href="https://m.eonline.com/au/amp/news/992885/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist">
	
	
	
	
		<meta name="googlebot-news" content="noindex">
	
	
	

	

	

	
		<meta name="news_keywords" content="arrow, the cw, katherine mcnamara, stephen amell, emily bett rickards">
	

	
	<meta name="tp:PreferredRuntimes" content="universal,html5,flash">
	<meta name="tp:PreferredFormats" content="MPEG4,M3U">

	
	<meta name="google-site-verification" content="jOadQCDbZTkKw5sn27yXszjIb9c3PdMPHENN92uPWy8" />




		
		

		
		










<script src="/dist/js/vendor.57c8b347e2ec7e75aa6a.js"></script>
<script src="/dist/js/head.resources.1.27bc1e094697ddc9d289.js"></script>








<script type="text/javascript">
	var wa = wa || {
		site: {
			edition: {
				content: "au",
				geo: jQuery.cookie("geoEdition"),
				ad: jQuery.cookie("adEdition")
			},
			experience: 'desktop'
		}
	};
</script>



	
	
		
		
			
				
					<script src="//assets.adobedtm.com/40c5e2c2fd7b89c305112b620e8ba76af1e548fe/satelliteLib-90d98ff908836445257862774a980980cee4ecb6.js"></script>
				
				
			
		

	










<script>
	var _comscore = _comscore || [];
	_comscore.push({ c1: "2", c2: "6035083", c3: "", c4: "", cs_ucfr: "0" });
	(function(){ 
		var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
		s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
		el.parentNode.insertBefore(s, el); 
	})(); 
</script>
<noscript>
	<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035083&c3=&c4=&c5=&c6=&c15=&cv=2.0&cj=1" />
</noscript>








<link type="text/css" rel="stylesheet" href="https://fonts.googleapis.com/css?family=Lato:400,400i,700,700i,900,900i|Oswald:400,300,700">
<link type="text/css" rel="stylesheet" href="/dist/css/head.resources.1.e0966869aed985391927.css">
<link type="text/css" rel="stylesheet" href="/dist/css/all.widgets.2.97390a716f88ed7662b0.css">













	
	        
		 
	
	
	
	
	
	
			
		
				
				




<script>
var eol_fw_ad_policy = "policy%3D44107";
var eol_fw_ad_policy_num = "44107";
</script>


<script id="js-evideo" data-edomain="www.eonline.com" data-edition="au" data-port="80"
 data-embed-code="&lt;/&gt;&nbsp;Get Embed Code" data-to-copy="CTRL-C or CMD-C to copy, then press Enter"
 data-copy="COPY"></script>





	
	




<script>
	// Static MPS values
	var mpsopts = {'updatecorrelator':true, 'host': "mps.nbcuni.com" };

	// Define Specific MPS values for Page
	var mpscall={
	    'site': "eonline-web",
	    'path': "", // unique path value for page GETS DYNAMICALLY SET BY MPS 
	    'cag[locale]': decodeURIComponent(document.cookie.replace(new RegExp("(?:(?:^|.*;)\\s*adEdition\\s*\\=\\s*([^;]*).*$)|^.*$"), "$1")) || "us", // akamai cookie || default us
	};

	
		
		
			mpscall['is_content'] = 1; // 1 for articles & 

			
				mpscall["content_id"] = '992885';
						
		
	
	
		mpscall['cag[topics]'] = "tv|top stories|arrow|entertainment|apple news"; //pipe delim list of all topics
	
	

		
			
			
				mpscall['cag[primary]'] = "tv"; //primary topic

				
					mpscall['cat'] = "topics|"+mpscall['cag[primary]']+"|news detail";
				
			
			
	
	
	
		mpscall['type'] = 'news detail';
		
        
	
	
	var mps=mps||{};mps._ext=mps._ext||{};mps._adsheld=[];mps._queue=mps._queue||{};mps._queue.mpsloaded=mps._queue.mpsloaded||[];mps._queue.mpsinit=mps._queue.mpsinit||[];mps._queue.gptloaded=mps._queue.gptloaded||[];mps._queue.adload=mps._queue.adload||[];mps._queue.adclone=mps._queue.adclone||[];mps._queue.adview=mps._queue.adview||[];mps._queue.refreshads=mps._queue.refreshads||[];mps.__timer=Date.now();mps.__intcode="v2";if(typeof mps.getAd!="function")mps.getAd=function(adunit){if(typeof adunit!="string")return false;var slotid="mps-getad-"+adunit.replace(/\W/g,"");if(!mps._ext||!mps._ext.loaded){mps._queue.gptloaded.push(function(){typeof mps._gptfirst=="function"&&mps._gptfirst(adunit,slotid);mps.insertAd("#"+slotid,adunit)});mps._adsheld.push(adunit)}return'<div id="'+slotid+'" class="mps-wrapper" data-mps-fill-slot="'+adunit+'"></div>'};(function(){head=document.head||document.getElementsByTagName("head")[0],mpsload=document.createElement("script");mpsload.src="//"+mpsopts.host+"/fetch/ext/load-"+mpscall.site+".js?nowrite=2";mpsload.id="mps-load";head.insertBefore(mpsload,head.firstChild)})();
</script>




		
		






<link type="text/css" rel="stylesheet" href="/dist/css/article.detail.7.308ff0ecdf5938fa784b.css" />

<script>
    (function($){
        /* Set the framework type as soon as we can so that there isn't a "jump"
           going from fw lrg 1280 to 980, since this jsp loads in the <head> */
        var winWidth = $(window).width();
        if(winWidth <= 1280 && 'false' === "false"){
            $('html').addClass('fw--md');
        }
    })(jQuery);
</script>


<script>
(function($){
    if(navigator.userAgent.match(/iPad/i) == null) {
		$("html").addClass("no-touch");
	} else {$("html").addClass("touch");}

})(jQuery);
</script>




<meta name="sailthru.date" content="2018-12-03 18:00:00" />

<meta name="sailthru.title" content="Arrow&#39;s Mystery Deepens With Katherine McNamara&#39;s Arrival &amp; Huge Green Arrow Twist" />
<meta name="sailthru.tags" content="arrow,tv,top_stories,entertainment,apple_news" />
<meta name="sailthru.edition" content="au" />


<meta itemprop="datePublished" content="2018-12-03T18:00:00Z" />
<meta itemprop="dateModified" content="2018-12-03T18:01:04Z" />

<script type="text/javascript" src="https://pdk.theplatform.com/next/pdk/tpPdk.js"></script>

<script type="text/javascript">
(function() { 
    function loadHorizon() { 
        var s = document.createElement('script'); 
        s.type = 'text/javascript'; 
        s.async = true; 
        s.src = location.protocol + '//ak.sail-horizon.com/horizon/v1.js'; 
        var x = document.getElementsByTagName('script')[0]; 
        x.parentNode.insertBefore(s, x); 
    } 
    loadHorizon(); 
    var oldOnLoad = window.onload; 
    window.onload = function() { 
        if (typeof oldOnLoad === 'function') { 
            oldOnLoad(); 
        } 
        Sailthru.setup({ 
            domain: 'horizon.eonline.com' 
        }); 
    }; 
})(); 
</script> 

<script id="adp-js" type="text/javascript" src="/dist/js/article.detail.7.c6525d725e7ef22bb702.js" data-v-gallery="false"></script>

	</head>

	
		
		
			
		
		

	
	<body 
		id="detail" 
		class=" eol news  edition_au js-onee-script"
		data-edition="au" 
		data-isEditionOptInEnabled="true" 
		data-editionOptInType="default"
		data-pagetype="NEWS_DETAIL">

		<div class="leaderboard" data-hook="leaderboard">
			<div class="nav__adbanner" data-hook="navadbanner">

























	










	




			
	
		<div  id="top-banner"  data-slot="topbanner"   data-render-ad="instant" class="mps-ad" ></div>
	



	<script>
		if (typeof mps === 'object') {
			console.log('eolMpsAd Instant', 'topbanner');
			
			mps._queue=mps._queue||{}; mps._queue.gptloaded=mps._queue.gptloaded||[];
			mps._queue.gptloaded.push(function() {
				mps.insertAd(mps._select('#top-banner'), 'topbanner', '');
			});
		}
	</script>


</div>
			<div class="lp_wrap">
				










	
		
	
	






	
		
	
	
	
	
	
	
	
	
	


<div class="nav__wrapper" id="nav__wrapper">
	<div class="nav" id="HHeader" data-nav-info='{"edition" : "au"}' data-hook="main-nav">
		<div class="nav__extender nav__extender--left">
			<div class="extender-bkg"></div>
		</div>
		<div class="nav__extender nav__extender--right"></div>
		<div class="nav__nav-base">
			<div class="nav__first-group">
				
				
				
				
				
				
				
				
				
				
				
				
					
					
					
					
						
						
							
							
								
							
						
					
				
				<a class="nav__logo-link nav__logo-link--default nav__logo-link--default-branding"
				 href="/au/" data-omniture='trackNavElement|{"products":";top-navigation:e-logo;;;event21=1","eVar16":"top-navigation:e-logo","eVar17":"top-navigation:e-logo:/","prop17":"top-navigation:e-logo:nav-item:e-logo","eVar42":"navigation","prop42":"navigation"}'></a>
			</div>
			<div class="nav__second-group">
				<div class="nav__middle-slot">
					
				</div>
				<ul class="nav__menu-main">
					
					
						
						

						<li class="nav__menu-item">
							
								
									<a href="https://www.eonline.com/au/news" data-omniture='trackNavElement|{ "products" : ";top-navigation:latest-news;;;event21=1", "eVar16" : "top-navigation:latest-news", "eVar17" : "top-navigation:latest-news:https://www.eonline.com/au/news", "prop17" : "top-navigation:latest-news:nav-item:latest-news", "eVar42" : "navigation", "prop42" : "navigation" }'>LATEST NEWS</a>
								
								
							
							
							
						</li>
					
						
						

						<li class="nav__menu-item">
							
								
									<a href="https://www.eonline.com/au/news/lifestyle" data-omniture='trackNavElement|{ "products" : ";top-navigation:lifestyle;;;event21=1", "eVar16" : "top-navigation:lifestyle", "eVar17" : "top-navigation:lifestyle:https://www.eonline.com/au/news/lifestyle", "prop17" : "top-navigation:lifestyle:nav-item:lifestyle", "eVar42" : "navigation", "prop42" : "navigation" }'>LIFE/STYLE</a>
								
								
							
							
							
								<ul class="nav__subnav">
									
										<li>
											

											<a href="https://www.eonline.com/au/news/beauty" data-omniture='trackNavElement|{ "products" : ";top-navigation:beauty;;;event21=1", "eVar16" : "top-navigation:beauty", "eVar17" : "top-navigation:beauty:https://www.eonline.com/au/news/beauty", "prop17" : "top-navigation:beauty:nav-item:beauty", "eVar42" : "navigation", "prop42" : "navigation" }'>BEAUTY</a>
										</li>
									
										<li>
											

											<a href="https://www.eonline.com/au/news/fashion" data-omniture='trackNavElement|{ "products" : ";top-navigation:fashion;;;event21=1", "eVar16" : "top-navigation:fashion", "eVar17" : "top-navigation:fashion:https://www.eonline.com/au/news/fashion", "prop17" : "top-navigation:fashion:nav-item:fashion", "eVar42" : "navigation", "prop42" : "navigation" }'>FASHION</a>
										</li>
									
										<li>
											

											<a href="https://www.eonline.com/au/news/fitness" data-omniture='trackNavElement|{ "products" : ";top-navigation:fitness;;;event21=1", "eVar16" : "top-navigation:fitness", "eVar17" : "top-navigation:fitness:https://www.eonline.com/au/news/fitness", "prop17" : "top-navigation:fitness:nav-item:fitness", "eVar42" : "navigation", "prop42" : "navigation" }'>FITNESS</a>
										</li>
									
										<li>
											

											<a href="https://www.eonline.com/au/news/home" data-omniture='trackNavElement|{ "products" : ";top-navigation:home;;;event21=1", "eVar16" : "top-navigation:home", "eVar17" : "top-navigation:home:https://www.eonline.com/au/news/home", "prop17" : "top-navigation:home:nav-item:home", "eVar42" : "navigation", "prop42" : "navigation" }'>HOME</a>
										</li>
									
										<li>
											

											<a href="https://www.eonline.com/au/news/travel" data-omniture='trackNavElement|{ "products" : ";top-navigation:travel;;;event21=1", "eVar16" : "top-navigation:travel", "eVar17" : "top-navigation:travel:https://www.eonline.com/au/news/travel", "prop17" : "top-navigation:travel:nav-item:travel", "eVar42" : "navigation", "prop42" : "navigation" }'>TRAVEL</a>
										</li>
									
								</ul>
							
						</li>
					
						
						

						<li class="nav__menu-item">
							
								
									<a href="https://www.eonline.com/au/news/royals" data-omniture='trackNavElement|{ "products" : ";top-navigation:royals;;;event21=1", "eVar16" : "top-navigation:royals", "eVar17" : "top-navigation:royals:https://www.eonline.com/au/news/royals", "prop17" : "top-navigation:royals:nav-item:royals", "eVar42" : "navigation", "prop42" : "navigation" }'>ROYALS</a>
								
								
							
							
							
						</li>
					
						
						

						<li class="nav__menu-item">
							
								
									<a href="https://www.eonline.com/au/shows/kardashians" data-omniture='trackNavElement|{ "products" : ";top-navigation:kardashians;;;event21=1", "eVar16" : "top-navigation:kardashians", "eVar17" : "top-navigation:kardashians:https://www.eonline.com/au/shows/kardashians", "prop17" : "top-navigation:kardashians:nav-item:kardashians", "eVar42" : "navigation", "prop42" : "navigation" }'>KARDASHIANS</a>
								
								
							
							
							
						</li>
					
						
						

						<li class="nav__menu-item">
							
								
									<a href="https://www.eonline.com/au/photos" data-omniture='trackNavElement|{ "products" : ";top-navigation:photos;;;event21=1", "eVar16" : "top-navigation:photos", "eVar17" : "top-navigation:photos:https://www.eonline.com/au/photos", "prop17" : "top-navigation:photos:nav-item:photos", "eVar42" : "navigation", "prop42" : "navigation" }'>PHOTOS</a>
								
								
							
							
							
						</li>
					
						
						

						<li class="nav__menu-item">
							
								
									<a href="https://www.eonline.com/au/videos" data-omniture='trackNavElement|{ "products" : ";top-navigation:videos;;;event21=1", "eVar16" : "top-navigation:videos", "eVar17" : "top-navigation:videos:https://www.eonline.com/au/videos", "prop17" : "top-navigation:videos:nav-item:videos", "eVar42" : "navigation", "prop42" : "navigation" }'>VIDEOS</a>
								
								
							
							
							
								<ul class="nav__subnav">
									
										<li>
											

											<a href="https://www.eonline.com/au/news/shoesday" data-omniture='trackNavElement|{ "products" : ";top-navigation:shoesday;;;event21=1", "eVar16" : "top-navigation:shoesday", "eVar17" : "top-navigation:shoesday:https://www.eonline.com/au/news/shoesday", "prop17" : "top-navigation:shoesday:nav-item:shoesday", "eVar42" : "navigation", "prop42" : "navigation" }'>SHOESDAY</a>
										</li>
									
										<li>
											

											<a href="https://www.eonline.com/au/news/get_ready_with_me" data-omniture='trackNavElement|{ "products" : ";top-navigation:get-ready-with-me;;;event21=1", "eVar16" : "top-navigation:get-ready-with-me", "eVar17" : "top-navigation:get-ready-with-me:https://www.eonline.com/au/news/get_ready_with_me", "prop17" : "top-navigation:get-ready-with-me:nav-item:get-ready-with-me", "eVar42" : "navigation", "prop42" : "navigation" }'>GET READY WITH ME</a>
										</li>
									
										<li>
											

											<a href="https://www.eonline.com/au/news/style_files" data-omniture='trackNavElement|{ "products" : ";top-navigation:style-files;;;event21=1", "eVar16" : "top-navigation:style-files", "eVar17" : "top-navigation:style-files:https://www.eonline.com/au/news/style_files", "prop17" : "top-navigation:style-files:nav-item:style-files", "eVar42" : "navigation", "prop42" : "navigation" }'>STYLE FILES</a>
										</li>
									
										<li>
											

											<a href="https://www.eonline.com/au/news/hooked_on_a_look" data-omniture='trackNavElement|{ "products" : ";top-navigation:hooked-on-a-look;;;event21=1", "eVar16" : "top-navigation:hooked-on-a-look", "eVar17" : "top-navigation:hooked-on-a-look:https://www.eonline.com/au/news/hooked_on_a_look", "prop17" : "top-navigation:hooked-on-a-look:nav-item:hooked-on-a-look", "eVar42" : "navigation", "prop42" : "navigation" }'>HOOKED ON A LOOK</a>
										</li>
									
								</ul>
							
						</li>
					
						
						

						<li class="nav__menu-item">
							
								
									<a href="https://www.eonline.com/au/shows" data-omniture='trackNavElement|{ "products" : ";top-navigation:e-shows;;;event21=1", "eVar16" : "top-navigation:e-shows", "eVar17" : "top-navigation:e-shows:https://www.eonline.com/au/shows", "prop17" : "top-navigation:e-shows:nav-item:e-shows", "eVar42" : "navigation", "prop42" : "navigation" }'>E! SHOWS</a>
								
								
							
							
							
								<ul class="nav__subnav">
									
										<li>
											

											<a href="https://www.eonline.com/au/shows/schedule" data-omniture='trackNavElement|{ "products" : ";top-navigation:tv-schedule;;;event21=1", "eVar16" : "top-navigation:tv-schedule", "eVar17" : "top-navigation:tv-schedule:https://www.eonline.com/au/shows/schedule", "prop17" : "top-navigation:tv-schedule:nav-item:tv-schedule", "eVar42" : "navigation", "prop42" : "navigation" }'>TV SCHEDULE</a>
										</li>
									
										<li>
											

											<a href="https://www.eonline.com/au/shows/kardashians" data-omniture='trackNavElement|{ "products" : ";top-navigation:kardashians;;;event21=1", "eVar16" : "top-navigation:kardashians", "eVar17" : "top-navigation:kardashians:https://www.eonline.com/au/shows/kardashians", "prop17" : "top-navigation:kardashians:nav-item:kardashians", "eVar42" : "navigation", "prop42" : "navigation" }'>KARDASHIANS</a>
										</li>
									
										<li>
											

											<a href="https://www.eonline.com/au/shows/busy_tonight" data-omniture='trackNavElement|{ "products" : ";top-navigation:busy-tonight;;;event21=1", "eVar16" : "top-navigation:busy-tonight", "eVar17" : "top-navigation:busy-tonight:https://www.eonline.com/au/shows/busy_tonight", "prop17" : "top-navigation:busy-tonight:nav-item:busy-tonight", "eVar42" : "navigation", "prop42" : "navigation" }'>BUSY TONIGHT</a>
										</li>
									
										<li>
											

											<a href="https://www.eonline.com/au/shows/the_bi_life" data-omniture='trackNavElement|{ "products" : ";top-navigation:the-bi-life;;;event21=1", "eVar16" : "top-navigation:the-bi-life", "eVar17" : "top-navigation:the-bi-life:https://www.eonline.com/au/shows/the_bi_life", "prop17" : "top-navigation:the-bi-life:nav-item:the-bi-life", "eVar42" : "navigation", "prop42" : "navigation" }'>THE BI LIFE</a>
										</li>
									
										<li>
											

											<a href="https://www.eonline.com/au/shows/e_news" data-omniture='trackNavElement|{ "products" : ";top-navigation:e-news;;;event21=1", "eVar16" : "top-navigation:e-news", "eVar17" : "top-navigation:e-news:https://www.eonline.com/au/shows/e_news", "prop17" : "top-navigation:e-news:nav-item:e-news", "eVar42" : "navigation", "prop42" : "navigation" }'>E! NEWS</a>
										</li>
									
										<li>
											

											<a href="https://www.eonline.com/au/shows/daily_pop" data-omniture='trackNavElement|{ "products" : ";top-navigation:daily-pop;;;event21=1", "eVar16" : "top-navigation:daily-pop", "eVar17" : "top-navigation:daily-pop:https://www.eonline.com/au/shows/daily_pop", "prop17" : "top-navigation:daily-pop:nav-item:daily-pop", "eVar42" : "navigation", "prop42" : "navigation" }'>DAILY POP</a>
										</li>
									
										<li>
											

											<a href="https://www.eonline.com/au/shows" data-omniture='trackNavElement|{ "products" : ";top-navigation:more-shows;;;event21=1", "eVar16" : "top-navigation:more-shows", "eVar17" : "top-navigation:more-shows:https://www.eonline.com/au/shows", "prop17" : "top-navigation:more-shows:nav-item:more-shows", "eVar42" : "navigation", "prop42" : "navigation" }'>MORE SHOWS</a>
										</li>
									
								</ul>
							
						</li>
					
						
						

						<li class="nav__menu-item">
							
								
									<a href="https://www.eonline.com/au/shows/the_hype" data-omniture='trackNavElement|{ "products" : ";top-navigation:the-hype;;;event21=1", "eVar16" : "top-navigation:the-hype", "eVar17" : "top-navigation:the-hype:https://www.eonline.com/au/shows/the_hype", "prop17" : "top-navigation:the-hype:nav-item:the-hype", "eVar42" : "navigation", "prop42" : "navigation" }'>THE HYPE</a>
								
								
							
							
							
						</li>
					
						
						

						<li class="nav__menu-item">
							
								
								
									
									<div class="nav__no-link" data-parent-nav-item-text="contact">CONTACT</div>
								
							
							
							
								<ul class="nav__subnav">
									
										<li>
											

											<a href="mailto:enewsau@nbcuni.com" data-omniture='trackNavElement|{ "products" : ";top-navigation:general;;;event21=1", "eVar16" : "top-navigation:general", "eVar17" : "top-navigation:general:mailto:enewsau@nbcuni.com", "prop17" : "top-navigation:general:nav-item:general", "eVar42" : "navigation", "prop42" : "navigation" }'>GENERAL</a>
										</li>
									
										<li>
											

											<a href="mailto:peter.harrison@nbcuni.com;giselle.gonzales@nbcuni.com" data-omniture='trackNavElement|{ "products" : ";top-navigation:advertise;;;event21=1", "eVar16" : "top-navigation:advertise", "eVar17" : "top-navigation:advertise:mailto:peter.harrison@nbcuni.com;giselle.gonzales@nbcuni.com", "prop17" : "top-navigation:advertise:nav-item:advertise", "eVar42" : "navigation", "prop42" : "navigation" }'>ADVERTISE</a>
										</li>
									
								</ul>
							
						</li>
					
				</ul>
			</div>
			<div class="nav__third-group">
				<ul class="nav__menu-intl">
					<li><a class="nav__menu-intl-current" href="javascript:void(0)" data-link="unbind-omniture">au</a></li>
					<li class="nav__menu-intl-menuitem"><a class="nav__au" href="/au" data-omniture='trackElement|{"products":";top-navigation:edition;;;event21=1","eVar16":"top-navigation:edition","eVar17":"top-navigation:edition:/au","prop17":"top-navigation:edition:edition-link:australia","eVar42":"navigation","prop42":"navigation"}'>Australia</a></li>
					<li class="nav__menu-intl-menuitem"><a class="nav__ap" href="/ap" data-omniture='trackElement|{"products":";top-navigation:edition;;;event21=1","eVar16":"top-navigation:edition","eVar17":"top-navigation:edition:/ap","prop17":"top-navigation:edition:edition-link:asia","eVar42":"navigation","prop42":"navigation"}'>Asia</a></li>
					<li class="nav__menu-intl-menuitem"><a class="nav__de" href="/de" data-omniture='trackElement|{"products":";top-navigation:edition;;;event21=1","eVar16":"top-navigation:edition","eVar17":"top-navigation:edition:/de","prop17":"top-navigation:edition:edition-link:germany","eVar42":"navigation","prop42":"navigation"}'>Germany</a></li>
					<li class="nav__menu-intl-menuitem"><a class="nav__fr" href="/fr" data-omniture='trackElement|{"products":";top-navigation:edition;;;event21=1","eVar16":"top-navigation:edition","eVar17":"top-navigation:edition:/fr","prop17":"top-navigation:edition:edition-link:france","eVar42":"navigation","prop42":"navigation"}'>France</a></li>
					<li class="nav__menu-intl-menuitem"><a class="nav__uk" href="/uk" data-omniture='trackElement|{"products":";top-navigation:edition;;;event21=1","eVar16":"top-navigation:edition","eVar17":"top-navigation:edition:/uk","prop17":"top-navigation:edition:edition-link:uk","eVar42":"navigation","prop42":"navigation"}'>UK</a></li>
					<li class="nav__menu-intl-menuitem"><a class="nav__ca" href="/ca" data-omniture='trackElement|{"products":";top-navigation:edition;;;event21=1","eVar16":"top-navigation:edition","eVar17":"top-navigation:edition:/ca","prop17":"top-navigation:edition:edition-link:canada","eVar42":"navigation","prop42":"navigation"}'>Canada</a></li>
					<li class="nav__menu-intl-menuitem"><a class="nav__us" href="/" data-omniture='trackElement|{"products":";top-navigation:edition;;;event21=1","eVar16":"top-navigation:edition","eVar17":"top-navigation:edition:/","prop17":"top-navigation:edition:edition-link:usa","eVar42":"navigation","prop42":"navigation"}'>USA</a></li>

					
						
							<li class="nav__menu-intl-menuitem"><a class="nav__mx" href="/mx" data-omniture='trackElement|{"products":";top-navigation:edition;;;event21=1","eVar16":"top-navigation:edition","eVar17":"top-navigation:edition:/mx","prop17":"top-navigation:edition:edition-link:mexico","eVar42":"navigation","prop42":"navigation"}'
								 rel="noopener">Mexico</a></li>
							<li class="nav__menu-intl-menuitem"><a class="nav__br" href="/br" data-omniture='trackElement|{"products":";top-navigation:edition;;;event21=1","eVar16":"top-navigation:edition","eVar17":"top-navigation:edition:/br","prop17":"top-navigation:edition:edition-link:brazil","eVar42":"navigation","prop42":"navigation"}'>Brazil</a></li>
							<li class="nav__menu-intl-menuitem"><a class="nav__ar" href="/ar" data-omniture='trackElement|{"products":";top-navigation:edition;;;event21=1","eVar16":"top-navigation:edition","eVar17":"top-navigation:edition:/ar","prop17":"top-navigation:edition:edition-link:argentina","eVar42":"navigation","prop42":"navigation"}'>Argentina</a></li>
							<li class="nav__menu-intl-menuitem"><a class="nav__co" href="/co" data-omniture='trackElement|{"products":";top-navigation:edition;;;event21=1","eVar16":"top-navigation:edition","eVar17":"top-navigation:edition:/co","prop17":"top-navigation:edition:edition-link:colombia","eVar42":"navigation","prop42":"navigation"}'>Colombia</a></li>
							<li class="nav__menu-intl-menuitem"><a class="nav__ve" href="/ve" data-omniture='trackElement|{"products":";top-navigation:edition;;;event21=1","eVar16":"top-navigation:edition","eVar17":"top-navigation:edition:/ve","prop17":"top-navigation:edition:edition-link:venezuela","eVar42":"navigation","prop42":"navigation"}'>Venezuela</a></li>
						
						
					
				</ul>
				<div class="nav__search">
					<a href="#" class="nav__search-button" data-link="unbind-omniture"></a>
					<div class="nav__search-form">
						<form class="nav__form" action="/au/search">
							<label class="nav__form-label">
								Press Enter to Search</label>
							<input class="nav__form-textarea" type="text" value="" name="query" autocomplete="on" />
							<input class="nav__form-submit" type="submit" value="" />
						</form>
					</div>
				</div>
			</div>
		</div>
	</div>
</div>



			</div>
		</div>
		

		<div class="eol-outerwrapper" data-hook="eol-outerwrapper"> 

			

			
			<div id="page" class="lp_wrap">
				


























		
	
















	
		
	



<script type="text/javascript">
 var tpLogLevel = "error";

 function fw_config(){
 	return evideo.getFreewheelConfig('article', '');
 }

	/* ===| *BEGIN* SET OMNITURE NATIVE CONTENT VARIABLE |=== */
	/*
		- execute very early, before tracking.jsp (s.tl function call)
		- execute after wa object is created
	*/
	// avoid wa object undefined error on pages in which wa is possibly not defined
	var wa = wa || {};

	wa.page = wa.page || {};
	wa.page.content = wa.page.content || {};
	

	// check if page has branded content enabled
	if (false) {
		wa.page.content.native = "native";
	} else {
		wa.page.content.native = "not-native";
	}
	/* ====| *END* SET OMNITURE NATIVE CONTENT VARIABLE |==== */

	eolMpsAd.isSkinBleed = true;  // for mps skin ad
</script>


 














	




	



	
	
	
		
		
				
			
		
	



	
	
		
		
		
			
			
				

				

				

			
		
	
	



<div id="article-detail" class="article-detail" 
		data-swiftype-index="true" 
		data-swiftype-name="body" 
		data-swiftype-type="text"
		data-twitter-title="Arrow's Mystery Deepens With Katherine McNamara's Arrival"
		data-video-dock-suppressed="true">

	
	
	

	
	

	<div class="article-meta  ">
		
		
		




		<h1 class="article__title">
			<i>Arrow</i>'s Mystery Deepens With Katherine McNamara's Arrival & Huge Green Arrow Twist
		</h1>
		
		
		





<div class="presented-by" data-swiftype-index="false">
	<div
		id="presented-by__bar"
		class="presented-by__bar"
		data-has-byline-override="false"
		data-has-adkeyword="false"
	>
		<ul class="l-grid presented-by--spacing">
			
			
				
				
					
					<li class="presented-by--v-centered">
						<div class="presented-by__textbox">
							<div class="presented-by__default-byline-element">By</div>
							<div class="presented-by__default-byline-element"><div class="e-logo--xs"></div>
						<div class="presented-by__default-byline-element">&</div>
						</div>					
					</li>

				
			
						

		</ul>
	</div>
	<div class="presented-by__divider"></div>
</div>

		
		
		








<p class="entry-meta" data-swiftype-index="false">
	<span class="entry-meta__author">
		<span class="u-lc">by</span>
		

		
			
				
					<a href="/authors/lauren-piester">Lauren Piester</a>
				
				
			
			
		
	</span>
	
	|
	
		
		
		
			<span class="entry-meta__time">
				








	
	
	
	
	
	
		
		Mon., Dec. 3, 2018 6:00 PM	
	
	
			</span>
		
	
</p>

		
		

		















	
	
































	




	
	








<div id="article-detail-social-icons" class="cs-container" data-swiftype-index="false" data-omniture-info='{ "pagename" : "tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "widgetType" : "share:social", "pageType" : "text-blocks" }'>
	<ul class="cs-list clear">
		
			<li class="cs-fb cs-item">
				<div class="cs-share"  >
					<span class="cs-sharetext">Share</span>
				</div>
				
			</li>
		
		
		<li  class="cs-ts cs-item">
			<div  class="cs-share" >
				<span class="cs-sharetext">Tweet</span>
			</div>
			
		</li>
		
			<li class="cs-gp cs-item">
				<div class="cs-share" >
					<span class="cs-sharetext">Share</span>
				</div>
				
			</li>
		
			
		
		
			<li id="email-bttn-article-detail-social-icons" class="cs-email cs-item">
				<div  class="cs-share email" >
					<span class="cs-sharetext">Email</span>
				</div>
			</li>
		
		
		
	</ul>
	
	
		<div id="preload_hovers_here-article-detail-social-icons" style="display: none;">
		   <!-- <img src="/resources/customSocialBar/images/google_hover.png" width="1" height="1" /> -->
		   <img src="/resources/customSocialBar/images/Facebook_hover.png" width="1" height="1" />
		   <img src="/resources/customSocialBar/images/twitter.png" width="1" height="1" />
		   <img src="/resources/customSocialBar/images/email_hover.png" width="1" height="1" />
		   
		</div>
	
</div>

	
	
		
			
		
		
		
		
		
		
	

	<script type="text/javascript">
		customSocialBar.globalSettings = {
				"twitterAccount" : "EOnlineAU",
				"i8nProductionDomain" : "https://www.eonline.com",
				"edition" : "au",
				"embedTop" : 40,
				"embedLeft" : 0
		}
	</script>












<script>
	//this is a var b/c we could reuse this articleDetailConfigJSON in the bottom social bar (but n change the containerID)
	(function(){
		
		var articleDetailConfigJSON = {
			"containerID" : "article-detail-social-icons",
			"tweetText" : "Arrow's Mystery Deepens With Katherine McNamara's Arrival",
			"getCountsOnLoad": true,
			"articleId": 992885
		};

		var articleDetailSocialBar = new customSocialBar(articleDetailConfigJSON);
		customSocialOmnitureHelper(articleDetailSocialBar); //activate default omniture
	})();

</script>

	</div>

	
	
	
	

	
		
		
		
			
			
		

		
		
			
			
				
				
				
			
		

		
		
		

		
		
			








<div id="block-0-img" class="post-content post-content--grouped " data-hook="scrollable-block" data-swiftype-index="false" >

	<div class="post-content__image">

		

		
			







		    
<div class="article_pinterest"></div>

<style>
.article_pinterest{background: url('/resources/images/pinterest/pinterest.png');height:51px;width:51px;}
.article_pinterest:hover{cursor:pointer;background:url('/resources/images/pinterest/pinterest_hover.png');height:51px;width:51px;}
</style>

<script> 
	var edition = 'au';
	var encodedShareURL = encodeURI('https://www.eonline.com/au/news/992885/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist');
	var imgSrc =  encodeURIComponent('https://akns-images.eonline.com/eol_images/Entire_Site/2018113/rs_1024x725-181203175131-1024x725.arrow-stephen-amell-emily-bett-rickards-lp.12318.jpg?fit=inside|900:auto&output-quality=90');
	var articleTitle = encodeURIComponent(jQuery(".entry_container .sub-headline").text());
	var imageTitle = encodeURIComponent("Arrow");
	var imageCaption = encodeURIComponent("Arrow");

	var titleJoin;
			
	function sharePinterest(){
	   	if (articleTitle.length > 1 && imageTitle.length > 1) {
			if (edition == 'de') {
				titleJoin = '%20%2D%20';
			} else if (edition == 'fr') {
				titleJoin = '%20de%20';
			} else {
				titleJoin = '%20from%20';
			}
		} else {
			titleJoin = "";
		}
		window.open('https://pinterest.com/pin/create/button/?url=' +  encodedShareURL + '&media=' + imgSrc + '&description=' + articleTitle + '%0A%0A' + imageCaption,  '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=253,width=750');
	}
	
	jQuery(".article_pinterest").click(function(){
				sharePinterest();
		});
	
</script>
		

		<img class="image--full" src="https://akns-images.eonline.com/eol_images/Entire_Site/2018113/rs_1024x725-181203175131-1024x725.arrow-stephen-amell-emily-bett-rickards-lp.12318.jpg?fit=inside|900:auto&output-quality=90" border="0" title="Arrow" alt="Arrow" data-width="1024" data-height="725" />

		
			<p class="image__credits">The CW</p>
		

		</div>

</div>








	

	<div id="photo-txt-0" class="post-content text-block clearfix post-content--groupedn-txt " data-hook="scrollable-block" >

		
		

		
		
		
				
				
				
					<section data-textblock-tracking="text-block-photo-text"><p>Jaws on the floor, anyone?&nbsp;</p><p>We went into tonight's <em>Arrow</em> thinking the biggest deal would be the arrival of <strong>Katherine McNamara</strong>'s Maya, but we were wrong. Sure, she got herself an epic entrance, taking down a guy twice in a cage match after the reveal that she was Blackstar, the person with whom Felicity last spoke before her alleged death. She didn't have much to say, but what she did say did not appear to be the whole truth, so clearly there's a lot more we have to learn from her.&nbsp;</p><p>The big surprise of the night was that the new Green Arrow is none other than Oliver Queen's secret half-sister! She's a badass who might be even better at exercising than Oliver himself, and at first, that's all we knew of her. Then, at the very end of this, the midseason/pre-crossover finale, she sat down in front of the grave of Robert Queen to pay tribute to her dad.&nbsp;</p><p>"Hey Dad, turns out Oliver's more like you than I thought. More like me, too. But I'm not giving up, not ever," she said. What does any of that even mean?&nbsp;</p></section>
				
		
	</div>


		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

	
		
	

	
		
		
		
			
			
		

		
		
			
			
				
				
				
			
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
			

	
	

	
	
	

	
		
		
			
		
		
		
	

	<div id="cta-1" class="post-content  cta  clearfix" data-hook="scrollable-block"  data-swiftype-index="false">

		
		
			<div class="column cta__thumb">
				
				
					
						
						
							<a class="image-button image-button--gallery clearfix" href="/photos/25853/everything-we-know-about-the-future-on-arrow"></a>
						
					

					<img class="image--full" src="https://akns-images.eonline.com/eol_images/Entire_Site/2018922/rs_600x600-181022153639-600x600.arrow-ben-lewis2-lp.102218.jpg?fit=inside|192:192&output-quality=90" />

				
			</div>
		

		<div class="column cta__text " data-textblock-tracking="text-block-cta" data-swiftype-index="false">
			
				<h2 class="cta__title">Photos</h2>
			
			<p><strong><a href="https://www.eonline.com/photos/25853/everything-we-know-about-the-future-on-arrow" target="_blank">Everything We Know About the Future on <em>Arrow</em></a></strong></p>
		</div>

		
			<a class="link--full-takeover" href="/photos/25853/everything-we-know-about-the-future-on-arrow" data-omniture='trackElement|{"linkTrackEvents":"event43","products":";text-block-cta;;;event43","eVar16":"text-block-cta","eVar17":"text-block-cta:/photos/25853/everything-we-know-about-the-future-on-arrow","prop17":"text-block-cta:hyperlink:everything-we-know-about-the-future-on-arrow","prop42":"text-blocks","eVar42":"text-blocks","linkName":"text-block-cta","appendLinkTrackVars":"prop9,prop14,prop15,prop62,prop72,eVar15,eVar62,eVar72,list1,"}'></a>
		
	</div>

	<div id="athena-1" class="athena__wrapper column cols--md-s" data-hook="scrollable-block">
		





































			
	
		<div  data-slot="athena1"   data-render-ad="onload" class="mps-ad" ></div>
	





	</div>
		
		

	
		
	

	
		
		
		
			
			
		

		
		
			
			
				
				
				
			
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

	
		
			



<div id="text-2" class="post-content text-block clearfix post-content--groupedn-txt " data-hook="scrollable-block" >

	
	
	
			
			
			
				<section data-textblock-tracking="text-block-text-only" data-swiftype-index="false"><p>Also in present day, we watched Oliver and Felicity come to terms with reality after Oliver's prison stint. Felicity has clearly been through some stuff, and Oliver's not very into the fact that she now carries a gun and is obsessed with security. Even after some very sexy and emotional moments post-prison, they ended things tonight on not such a happy note.&nbsp;</p><p>Oliver even asked what happened to the person he fell in love with, and Felicity icily responded: "She's gone, and she's not coming back." Ouch.&nbsp;</p><p>Later, they admitted their time apart had led them in different directions, and Felicity wondered if what was best for her was also best for them as a couple. And that's how they left things. While that was a concerning place to leave it, it sounds like it won't be too long before they figure out how to live with this new reality.&nbsp;</p></section>
			
	
</div>

		
	

	
		
		
		
			
			
		

		
		
			
			
				
				
				
			
		

		
		
		

		
		
			








<div id="block-3-img" class="post-content post-content--grouped " data-hook="scrollable-block" data-swiftype-index="false" >

	<div class="post-content__image">

		

		

		<img class="image--full" src="https://akns-images.eonline.com/eol_images/Entire_Site/2018113/rs_640x360-181203175853-Arrow-Unmasked-5_01_24_PM_-_5_01_29_PM-2018-12-03.gif?fit=inside|900:auto&output-quality=90" border="0" title="Arrow GIFs" alt="Arrow GIFs" data-width="640" data-height="360" />

		
			<p class="image__credits">The CW</p>
		

		</div>

</div>








	

	<div id="photo-txt-3" class="post-content text-block clearfix post-content--groupedn-txt " data-hook="scrollable-block" >

		
		

		
		
		
				
				
				
					<section data-textblock-tracking="text-block-photo-text"><p><span style="font-weight: 400;">"We&nbsp;</span><em><span style="font-weight: 400;">do</span></em><span style="font-weight: 400;">&nbsp;work it out pretty quickly," Amell said when we visited the set. "We come to an understanding that nothing's ever going to be perfect...One of the other things that we talked about a lot is Oliver can't live in a normal apartment building anymore, right? I thought that they should militarize the Queen mansion. I got shot down. I think we could afford to do that. But nothing's ever going to be perfect or normal about our relationship, and I think that the sooner that the two of them accept that, the sooner that they can move on with their lives."&nbsp;</span></p><p><span style="font-weight: 400;">So we can rest easy that Oliver and Felicity will figure it out, even if we can't rest easy that all will be well in the future.&nbsp;</span></p></section>
				
		
	</div>


		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

	
		
	

	
		
		
		
			
			
		

		
		
			
			
				
				
				
			
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
			

	
	

	
	
	

	
		
		
		
			
		
		
	

	<div id="cta-4" class="post-content  cta  clearfix" data-hook="scrollable-block"  data-swiftype-index="false">

		
		
			<div class="column cta__thumb">
				
				
					
						
						
					

					<img class="image--full" src="https://akns-images.eonline.com/eol_images/Entire_Site/2018113/rs_600x600-181203125215-600x600.arrow-flash-supergirl-elseworlds-lp.12318.jpg?fit=inside|192:192&output-quality=90" />

				
			</div>
		

		<div class="column cta__text " data-textblock-tracking="text-block-cta" data-swiftype-index="false">
			
				<h2 class="cta__title">Read</h2>
			
			<p><strong><a href="https://www.eonline.com/us/news/992356/the-elseworlds-arrowverse-crossover-is-going-to-be-so-epic" target="_blank">The <em>Elseworlds</em> Arrowverse Crossover Is Going to Be So Epic</a></strong></p>
		</div>

		
			<a class="link--full-takeover" href="/news/992356/the-elseworlds-arrowverse-crossover-is-going-to-be-so-epic" data-omniture='trackElement|{"linkTrackEvents":"event43","products":";text-block-cta;;;event43","eVar16":"text-block-cta","eVar17":"text-block-cta:/news/992356/the-elseworlds-arrowverse-crossover-is-going-to-be-so-epic","prop17":"text-block-cta:hyperlink:the-elseworlds-arrowverse-crossover-is-going-to-be-so-epic","prop42":"text-blocks","eVar42":"text-blocks","linkName":"text-block-cta","appendLinkTrackVars":"prop9,prop14,prop15,prop62,prop72,eVar15,eVar62,eVar72,list1,"}'></a>
		
	</div>

	<div id="athena-1" class="athena__wrapper column cols--md-s" data-hook="scrollable-block">
		





































			
	
		<div  data-slot="athena1"   data-render-ad="onload" class="mps-ad" ></div>
	





	</div>
		
		

	
		
	

	
		
		
		
			
			
		

		
		
			
			
				
				
				
			
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

	
		
			



<div id="text-5" class="post-content text-block clearfix post-content--groupedn-txt " data-hook="scrollable-block" >

	
	
	
			
			
			
				<section data-textblock-tracking="text-block-text-only" data-swiftype-index="false"><p>Speaking of which, back in the future, Blackstar tried to pretend she didn't even know Felicity but then admitted, "We work together, sometimes." She then implied that their work was illegal and confronted Dinah with a, "At least I'm not a vigilante." They then both tried to blame each other for the dismal unsaved state of the city.&nbsp;</p><p>"I work as a broker. I help people find certain items," Blackstar explained. "Felicity asked me to find her an electrical firing circuit and a couple transmitters...I don't know why she needed them, I didn't ask. As long as I get paid you can ask for whatever you want."&nbsp;</p><p>As William helpfully explained, an electrical firing circuit and transmitters are exactly what you need for an explosive device, like the kind you'd build for blowing up a city, which Felicity was apparently planning to do at some point.&nbsp;</p><p>William decided that Blackstar wasn't telling the whole truth,&nbsp;so he and the gang broke into her place and found the same bomb schematics Felicity had, which meant she definitely knew about Felicity's plan and probably planned to continue it.&nbsp;</p></section>
			
	
</div>

		
	

	
		
		
		
			
			
		

		
		
			
			
				
				
				
			
		

		
		
		

		
		
			








<div id="block-6-img" class="post-content post-content--grouped " data-hook="scrollable-block" data-swiftype-index="false" >

	<div class="post-content__image">

		

		

		<img class="image--full" src="https://akns-images.eonline.com/eol_images/Entire_Site/2018113/rs_640x360-181203175851-Arrow-Unmasked-5_05_11_PM_-_5_05_14_PM-2018-12-03.gif?fit=inside|900:auto&output-quality=90" border="0" title="Arrow GIFs" alt="Arrow GIFs" data-width="640" data-height="360" />

		
			<p class="image__credits">The CW</p>
		

		</div>

</div>








	

	<div id="photo-txt-6" class="post-content text-block clearfix post-content--groupedn-txt " data-hook="scrollable-block" >

		
		

		
		
		
				
				
				
					<section data-textblock-tracking="text-block-photo-text"><p>Other clues we're contemplating:&nbsp;</p><p>-Dinah explained the Mark of Four. It's basically a symbol the whole team got as a tattoo that represented their friendship and loyalty, and it's such a powerful symbol that it got Roy to come back to Star City. We were expecting something more exciting than that, but OK.&nbsp;</p><p>-Is Oliver also dead in the future? He's at least not a hero anymore, based on the way Dinah was talking about him. "...the strength that made him a hero," "your dad, he had this way of looking into things, of seeing beyond the evidence..." Made, had. Those are very past tense words, so at this point we're just hoping that Oliver retired and hid himself on an island somewhere, and now Felicity has just gone to join him, even if it would be super rude to leave a clueless William behind alone.&nbsp;</p><p>-As for that very final scene, it's the same scene that closed out <em>Supergirl</em> and <em>The Flash</em> this week, and it sets up what is sure to be <a href="https://www.eonline.com/news/992356/the-elseworlds-arrowverse-crossover-is-going-to-be-so-epic" target="_blank">one hell of a crossover</a>.&nbsp;</p><p>Finally, can we just take a moment to applaud these badass ladies showing off some serious skills this episode? Here. For. It!&nbsp;</p></section>
				
		
	</div>


		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

	
		
	

	
		
		
		
			
			
		

		
		
			
			
				
				
				
			
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

	
		
			



<div id="text-7" class="post-content text-block clearfix post-content--groupedn-txt " data-hook="scrollable-block" >

	
	
	
			
			
			
				<section data-textblock-tracking="text-block-text-only" data-swiftype-index="false"><p><em>Arrow</em> airs Mondays at 8 p.m. on the CW.&nbsp;</p></section>
			
	
</div>

		
	

	

	



























 	
		
			<script>
				window._taboola = window._taboola || [];
				
					
					
						_taboola.push({ "article": 'auto' });
					
				
				
				!function (e, f, u, i) {
					if (!document.getElementById(i)){
					e.async = 1;
					e.src = u;
					e.id = i;
					f.parentNode.insertBefore(e, f);
					}
				}(document.createElement('script'),
				document.getElementsByTagName('script')[0],
				'//cdn.taboola.com/libtrc/eonline-network/loader.js',
				'tb_loader_script');
				if(window.performance && typeof window.performance.mark == 'function') {
					window.performance.mark('tbl_ic');
				}

			</script>
		


		
			<div id="taboola-article" class="post-content">
				<div id="taboola-below-article-thumbnails" ></div>
			</div>
		
		
	


	
	


	
	

<div class="post-content" data-hook="scrollable-block">
	




























	











<div id="social-bar--bottom-centered" class="cs-container" data-swiftype-index="false" data-omniture-info='{ "pagename" : "tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "widgetType" : "share:social", "pageType" : "text-blocks" }'>
	<ul class="cs-list clear">
		
			<li class="cs-fb cs-item">
				<div class="cs-share"  >
					<span class="cs-sharetext">Share</span>
				</div>
				
			</li>
		
		
		<li  class="cs-ts cs-item">
			<div  class="cs-share" >
				<span class="cs-sharetext">Tweet</span>
			</div>
			
		</li>
		
			<li class="cs-gp cs-item">
				<div class="cs-share" >
					<span class="cs-sharetext">Share</span>
				</div>
				
			</li>
		
			
		
		
			<li id="email-bttn-social-bar--bottom-centered" class="cs-email cs-item">
				<div  class="cs-share email" >
					<span class="cs-sharetext">Email</span>
				</div>
			</li>
		
		
		
	</ul>
	
	
		<div id="preload_hovers_here-social-bar--bottom-centered" style="display: none;">
		   <!-- <img src="/resources/customSocialBar/images/google_hover.png" width="1" height="1" /> -->
		   <img src="/resources/customSocialBar/images/Facebook_hover.png" width="1" height="1" />
		   <img src="/resources/customSocialBar/images/twitter.png" width="1" height="1" />
		   <img src="/resources/customSocialBar/images/email_hover.png" width="1" height="1" />
		   
		</div>
	
</div>









</div>

<script type="text/javascript">
(function(){
	var articleDetailBottomConfigJSON = {
		"containerID" : "social-bar--bottom-centered",
		"tweetText" : "Arrow's Mystery Deepens With Katherine McNamara's Arrival",
		"getCountsOnLoad": false,
		"articleId": 992885
	};
	var articleDetailBottomSocialBar = new customSocialBar(articleDetailBottomConfigJSON);
	customSocialOmnitureHelper(articleDetailBottomSocialBar); //activate default omniture
})();
</script>
	
	
	



<div class="entry_footer post-content clear" data-swiftype-index="false" data-hook="scrollable-block">
	
		<div class="categories">
			<span class="categories__label">
				TAGS/
				</span>
			

			
				
			

			

				<a class="categories__link" href="/au/news/arrow" title="view all posts in Arrow" rel="category tag" data-omniture="news_detail:category_Arrow">Arrow</a>

				,
			

				<a class="categories__link" href="/au/news/tv" title="view all posts in TV" rel="category tag" data-omniture="news_detail:category_TV">TV</a>

				,
			

				<a class="categories__link" href="/au/news/top_stories" title="view all posts in Top Stories" rel="category tag" data-omniture="news_detail:category_Top Stories">Top Stories</a>

				,
			

				<a class="categories__link" href="/au/news/entertainment" title="view all posts in Entertainment" rel="category tag" data-omniture="news_detail:category_Entertainment">Entertainment</a>

				,
			

				<a class="categories__link" href="/au/news/apple_news" title="view all posts in Apple News" rel="category tag" data-omniture="news_detail:category_Apple News">Apple News</a>

				
			
		</div>
	
</div>

	<div class="post-content" data-hook="scrollable-block">
		











 












<button class="glossy__btn fb-comments-btn" data-hook="fb-comments-btn">
	Show Comments
</button>
<div class="fb-comments-container two-column--md" data-swiftype-index="false" data-hook="fbcomments">
	<div class="fb-comments" data-href="http://www.eonline.com/au/news/992885/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist" ></div>
</div>
 

	</div>

	
	







<div id="rail" class="rail rail--scrollable column--pos-r" data-swiftype-index="false">

	
	<div id="rail__mps" class="rail__mps-ad"></div>


	

	<section class="trending glossy-widget" 
			data-hook="trending-stories" 
			data-url="https://pf0ggtc38e.execute-api.us-west-2.amazonaws.com/prod"
			data-edition="au" 
			data-article-count="5" 
			data-tracking-name="trending-stories-right-rail"
			data-async-load-js-webpack="/dist/js/widgets.trending-stories.20.b86f4f2759aaf2a7cffc.js">
	
	<header class="glossy-header clearfix">
		<h2 class="glossy-header-container">
			<span class="glossy-header--prefix">Trending</span>
			<span class="glossy-header--suffix glossy-header--line">Stories</span>
		</h2>
		<div class="trending__bluebar"></div>
	</header>

		<div class="trending__content">
			
				<div class="trending__top-article-image" data-hook="top-article-image" data-tb-region-item>
					<div class="trending__top-article-image--placeholder">
						<div class="trending-loading-circle-wrapper">
							<div class="loading-circle"></div>
						</div>
					</div>
				</div>
			

			<ul class="trending__list trending__list--image " data-hook="trending-list-first">
				
					<li class="trending__list-item--placeholder trending__list-item--placeholder-title"
					 data-tb-region-item>
						<div class="loading-line"></div>
					</li>
				
					<li class="trending__list-item--placeholder "
					 data-tb-region-item>
						<div class="loading-line"></div>
					</li>
				
					<li class="trending__list-item--placeholder "
					 data-tb-region-item>
						<div class="loading-line"></div>
					</li>
				
					<li class="trending__list-item--placeholder "
					 data-tb-region-item>
						<div class="loading-line"></div>
					</li>
				
					<li class="trending__list-item--placeholder "
					 data-tb-region-item>
						<div class="loading-line"></div>
					</li>
				
			</ul>

		</div>

	</section>

	

		
		
		
			
		

		
			<div class="rail__title table__wrapper">
				<div class="table__inner">
					
						
						
							Latest News
						
					
				</div>
				<div class="rail__title-accent"></div>
			</div>
		

		
		

		<div class="rail__item rail__videos rail__videos--first" data-rail-tracking="right-rail-video">
			<a class="link--full rail__link rail__link--videos" href="/au/shows/e_news/videos/281461/beth-behrs-tichina-arnold-talk-neighborhood-chemistry" data-omniture='trackElement|{"linkTrackEvents":"event45","events":"event45","products":";right-rail-video;;;event45", "eVar42" : "right-rail", "prop42" : "right-rail", "eVar16":"right-rail-video","eVar17":"right-rail-video:/au/shows/e_news/videos/281461/beth-behrs-tichina-arnold-talk-neighborhood-chemistry","prop17":"right-rail-video:image:beth-behrs--tichina-arnold-talk-neighborhood-chemistry","linkName":"right-rail"}'>
				<img class="image--full" src="https://eonlinethumbs-a.akamaihd.net/images/25/375/enews_20181203_highlight_b_281461_560x315_1387706435957.jpg?fit=inside|300:300&output-quality=90" alt="" />
				<span class="rail__arrow"></span>
			</a>
			<p class="rail__text">
				<a class="link--full rail__link" href="/au/shows/e_news/videos/281461/beth-behrs-tichina-arnold-talk-neighborhood-chemistry" data-omniture='trackElement|{"linkTrackEvents":"event45","events":"event45","products":";right-rail-video;;;event45", "eVar42" : "right-rail", "prop42" : "right-rail", "eVar16":"right-rail-video","eVar17":"right-rail-video:/au/shows/e_news/videos/281461/beth-behrs-tichina-arnold-talk-neighborhood-chemistry","prop17":"right-rail-video:title:beth-behrs--tichina-arnold-talk-neighborhood-chemistry","linkName":"right-rail"}'>
					Beth Behrs & Tichina Arnold Talk "Neighborhood" Chemistry
				</a>
			</p>
		</div>

	

		
		
		

		

		
		

		<div class="rail__item rail__news" data-rail-tracking="right-rail-photo">
			<a class="link--full rail__link rail__link--news" href="/au/news/992837/the-flash-cast-celebrates-100-episodes-with-rapid-fire-scoop" data-omniture='trackElement|{"linkTrackEvents":"event45","events":"event45","products":";right-rail-photo;;;event45", "eVar42" : "right-rail", "prop42" : "right-rail", "eVar16":"right-rail-photo","eVar17":"right-rail-photo:/au/news/992837/the-flash-cast-celebrates-100-episodes-with-rapid-fire-scoop","prop17":"right-rail-photo:image:the-flash-cast-celebrates-100-episodes-with-rapid-fire-scoop","linkName":"right-rail"}'>
				<img class="image--full" src="https://images.eonline.com/eol_images/Entire_Site/2018113/rs_600x600-181203123030-600x600.the-flash-grant-gustin-candice-patton-lp.12318.jpg?fit=inside|300:300&output-quality=90" alt="The Flash" />
				
			</a>
			<p class="rail__text">
				<a class="link--full rail__link" href="/au/news/992837/the-flash-cast-celebrates-100-episodes-with-rapid-fire-scoop" data-omniture='trackElement|{"linkTrackEvents":"event45","events":"event45","products":";right-rail-photo;;;event45", "eVar42" : "right-rail", "prop42" : "right-rail", "eVar16":"right-rail-photo","eVar17":"right-rail-photo:/au/news/992837/the-flash-cast-celebrates-100-episodes-with-rapid-fire-scoop","prop17":"right-rail-photo:title:the-flash-cast-celebrates-100-episodes-with-rapid-fire-scoop","linkName":"right-rail"}'>
					<i>The Flash</i> Cast Celebrates 100 Episodes With Rapid Fire Scoop
				</a>
			</p>
		</div>

	

		
		
		
			
		

		

		
		
			
			<div id="rail__sharethrough"></div>
		

		<div class="rail__item rail__videos" data-rail-tracking="right-rail-video">
			<a class="link--full rail__link rail__link--videos" href="/au/shows/daily_pop/videos/280759/lala-kent-on-james-kennedy-being-friends-with-me-is-a-privilege" data-omniture='trackElement|{"linkTrackEvents":"event45","events":"event45","products":";right-rail-video;;;event45", "eVar42" : "right-rail", "prop42" : "right-rail", "eVar16":"right-rail-video","eVar17":"right-rail-video:/au/shows/daily_pop/videos/280759/lala-kent-on-james-kennedy-being-friends-with-me-is-a-privilege","prop17":"right-rail-video:image:lala-kent-on-james-kennedy-being-friends-with-me-is-a-privilege","linkName":"right-rail"}'>
				<img class="image--full" src="https://eonlinethumbs-a.akamaihd.net/images/232/895/pop_20181203_highlight_a_280759_560x315_1387608643586.jpg?fit=inside|300:300&output-quality=90" alt="" />
				<span class="rail__arrow"></span>
			</a>
			<p class="rail__text">
				<a class="link--full rail__link" href="/au/shows/daily_pop/videos/280759/lala-kent-on-james-kennedy-being-friends-with-me-is-a-privilege" data-omniture='trackElement|{"linkTrackEvents":"event45","events":"event45","products":";right-rail-video;;;event45", "eVar42" : "right-rail", "prop42" : "right-rail", "eVar16":"right-rail-video","eVar17":"right-rail-video:/au/shows/daily_pop/videos/280759/lala-kent-on-james-kennedy-being-friends-with-me-is-a-privilege","prop17":"right-rail-video:title:lala-kent-on-james-kennedy-being-friends-with-me-is-a-privilege","linkName":"right-rail"}'>
					Lala Kent on James Kennedy: "Being Friends With Me Is a Privilege"
				</a>
			</p>
		</div>

	

		
		
		

		

		
		

		<div class="rail__item rail__news" data-rail-tracking="right-rail-photo">
			<a class="link--full rail__link rail__link--news" href="/au/news/992618/friends-is-leaving-netflix-in-january-2019" data-omniture='trackElement|{"linkTrackEvents":"event45","events":"event45","products":";right-rail-photo;;;event45", "eVar42" : "right-rail", "prop42" : "right-rail", "eVar16":"right-rail-photo","eVar17":"right-rail-photo:/au/news/992618/friends-is-leaving-netflix-in-january-2019","prop17":"right-rail-photo:image:is-friends-leaving-netflix-in-january-2019","linkName":"right-rail"}'>
				<img class="image--full" src="https://images.eonline.com/eol_images/Entire_Site/201872/rs_600x600-180802100353-friends-serie-z.jpg?fit=inside|300:300&output-quality=90" alt="Friends" />
				
			</a>
			<p class="rail__text">
				<a class="link--full rail__link" href="/au/news/992618/friends-is-leaving-netflix-in-january-2019" data-omniture='trackElement|{"linkTrackEvents":"event45","events":"event45","products":";right-rail-photo;;;event45", "eVar42" : "right-rail", "prop42" : "right-rail", "eVar16":"right-rail-photo","eVar17":"right-rail-photo:/au/news/992618/friends-is-leaving-netflix-in-january-2019","prop17":"right-rail-photo:title:is-friends-leaving-netflix-in-january-2019","linkName":"right-rail"}'>
					Is <i>Friends</i> Leaving Netflix in January 2019?!
				</a>
			</p>
		</div>

	

		
		
		

		

		
		

		<div class="rail__item rail__news" data-rail-tracking="right-rail-photo">
			<a class="link--full rail__link rail__link--news" href="/au/news/992730/the-elseworlds-arrowverse-crossover-is-going-to-be-so-epic" data-omniture='trackElement|{"linkTrackEvents":"event45","events":"event45","products":";right-rail-photo;;;event45", "eVar42" : "right-rail", "prop42" : "right-rail", "eVar16":"right-rail-photo","eVar17":"right-rail-photo:/au/news/992730/the-elseworlds-arrowverse-crossover-is-going-to-be-so-epic","prop17":"right-rail-photo:image:the-elseworlds-arrowverse-crossover-is-going-to-be-so-epic","linkName":"right-rail"}'>
				<img class="image--full" src="https://images.eonline.com/eol_images/Entire_Site/2018113/rs_600x600-181203125215-600x600.arrow-flash-supergirl-elseworlds-lp.12318.jpg?fit=inside|300:300&output-quality=90" alt="Elseworlds, Arrow, The Flash, Supergirl" />
				
			</a>
			<p class="rail__text">
				<a class="link--full rail__link" href="/au/news/992730/the-elseworlds-arrowverse-crossover-is-going-to-be-so-epic" data-omniture='trackElement|{"linkTrackEvents":"event45","events":"event45","products":";right-rail-photo;;;event45", "eVar42" : "right-rail", "prop42" : "right-rail", "eVar16":"right-rail-photo","eVar17":"right-rail-photo:/au/news/992730/the-elseworlds-arrowverse-crossover-is-going-to-be-so-epic","prop17":"right-rail-photo:title:the-elseworlds-arrowverse-crossover-is-going-to-be-so-epic","linkName":"right-rail"}'>
					The <i>Elseworlds</i> Arrowverse Crossover Is Going to Be So Epic
				</a>
			</p>
		</div>

	

		
		
		

		

		
		

		<div class="rail__item rail__news" data-rail-tracking="right-rail-photo">
			<a class="link--full rail__link rail__link--news" href="/au/news/992704/lindsay-lohan-s-beach-club-promo-has-everything-you-want-including-the-lilo-dance" data-omniture='trackElement|{"linkTrackEvents":"event45","events":"event45","products":";right-rail-photo;;;event45", "eVar42" : "right-rail", "prop42" : "right-rail", "eVar16":"right-rail-photo","eVar17":"right-rail-photo:/au/news/992704/lindsay-lohan-s-beach-club-promo-has-everything-you-want-including-the-lilo-dance","prop17":"right-rail-photo:image:lindsay-lohans-beach-club-promo-has-everything-you-want-including-the-lilo-dance","linkName":"right-rail"}'>
				<img class="image--full" src="https://images.eonline.com/eol_images/Entire_Site/2018517/rs_600x600-180617190031-600-lindsay-lohan-061718.jpg?fit=inside|300:300&output-quality=90" alt="Lindsay Lohan" />
				
			</a>
			<p class="rail__text">
				<a class="link--full rail__link" href="/au/news/992704/lindsay-lohan-s-beach-club-promo-has-everything-you-want-including-the-lilo-dance" data-omniture='trackElement|{"linkTrackEvents":"event45","events":"event45","products":";right-rail-photo;;;event45", "eVar42" : "right-rail", "prop42" : "right-rail", "eVar16":"right-rail-photo","eVar17":"right-rail-photo:/au/news/992704/lindsay-lohan-s-beach-club-promo-has-everything-you-want-including-the-lilo-dance","prop17":"right-rail-photo:title:lindsay-lohans-beach-club-promo-has-everything-you-want-including-the-lilo-dance","linkName":"right-rail"}'>
					<i>Lindsay Lohan's Beach Club</i> Promo Has Everything You Want, Including the LiLo Dance
				</a>
			</p>
		</div>

	

		
		
		

		

		
		

		<div class="rail__item rail__news" data-rail-tracking="right-rail-photo">
			<a class="link--full rail__link rail__link--news" href="/au/news/992598/batman-who-ruby-rose-s-batwoman-gets-her-time-to-shine-in-elseworlds-teaser" data-omniture='trackElement|{"linkTrackEvents":"event45","events":"event45","products":";right-rail-photo;;;event45", "eVar42" : "right-rail", "prop42" : "right-rail", "eVar16":"right-rail-photo","eVar17":"right-rail-photo:/au/news/992598/batman-who-ruby-rose-s-batwoman-gets-her-time-to-shine-in-elseworlds-teaser","prop17":"right-rail-photo:image:batman-who-ruby-roses-batwoman-gets-her-time-to-shine-in-elseworlds-teaser","linkName":"right-rail"}'>
				<img class="image--full" src="https://images.eonline.com/eol_images/Entire_Site/2018113/rs_600x600-181203081740-600-2-batwoman-cw-ch-120318.jpg?fit=inside|300:300&output-quality=90" alt="Batwoman, Elseworlds, The Flash, Arrow, Supergirl" />
				
			</a>
			<p class="rail__text">
				<a class="link--full rail__link" href="/au/news/992598/batman-who-ruby-rose-s-batwoman-gets-her-time-to-shine-in-elseworlds-teaser" data-omniture='trackElement|{"linkTrackEvents":"event45","events":"event45","products":";right-rail-photo;;;event45", "eVar42" : "right-rail", "prop42" : "right-rail", "eVar16":"right-rail-photo","eVar17":"right-rail-photo:/au/news/992598/batman-who-ruby-rose-s-batwoman-gets-her-time-to-shine-in-elseworlds-teaser","prop17":"right-rail-photo:title:batman-who-ruby-roses-batwoman-gets-her-time-to-shine-in-elseworlds-teaser","linkName":"right-rail"}'>
					Batman Who? Ruby Rose's Batwoman Gets Her Time to Shine in &quot;Elseworlds&quot; Teaser
				</a>
			</p>
		</div>

	
</div>
</div>

<script type="text/javascript">
	if ((typeof(gapi) !== 'undefined') && (typeof(gapi.plusone) !== 'undefined') && (typeof(gapi.plusone.go) !== 'undefined')) {
		gapi.plusone.go("blog_roll");
	}
</script>







































			
	
		<div  data-slot="overlay"   data-render-ad="onload" class="mps-ad" ></div>
	











<script type="application/ld+json">
{
	"@context": "http://schema.org",
	"@type": "NewsArticle",
	"mainEntityofPage": {
		"@type": "WebPage",
		"@id": "https://www.eonline.com/au/news/992885/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist"
	},
	"keywords": "Arrow, TV, Top Stories, Entertainment, Apple News",
	"headline": "<i>Arrow</i>'s Mystery Deepens With Katherine McNamara's Arrival & Huge Green Arrow Twist",
	"image": {
		"@type": "ImageObject",
		"url": "https://akns-images.eonline.com/eol_images/Entire_Site/2018113/rs_600x600-181203175130-600x600.arrow-stephen-amell-emily-bett-rickards-lp.12318.jpg?fit=around|700:700&crop=700:700;center,top&output-quality=90",
		"width": 700,
		"height": 700
	},
	"datePublished": "2018-12-03T18:00:00",
	"dateModified": "2018-12-03T18:01:04",
	"author": {
		"@type": "Person",
		"name": "Lauren Piester"
	},
	"publisher": {
		"@type": "Organization",
		"name": "E! News",
		"logo": {
			"@type": "ImageObject",
			"url": "https://akns-images.eonline.com/eol_images/Entire_Site/201709/rs_100x60-170109133805-e-news-amp-logo-black.png",
			"width": 100,
			"height": 60
		}
	},
	"description": "So much just happened and we can't even deal with it "
}
</script>

	



				







    





<div class="footer" data-hook="footer">
    <div class="nav__extender nav__extender--left nav__extender--gray"></div>
    <div class="nav__extender nav__extender--right nav__extender--gray"></div>

    <div class="footer__socials">
        
            

            
                <a href="/au/" class="footer__enews-logo footer__enews-logo--au"
                    data-omniture='trackElement|{"linkName":"nav:footer:main","products":"eVar16=\"nav\""},"prop17":"eVar16=\"nav\"","eVar17":"eVar16=\"nav\"","eVar16":"frontdoor-modules"}'></a>
            
        

        <ul class="footer__social-list l-grid l-spacing--sm">
            <!-- FACEBOOK -->
            <li>
                <a href="https://www.facebook.com/eentertainmentau" class="social-link social-link--facebook"
                    target="_blank" data-omniture='trackElement|{"trackEvents":"event20,event21","products":";footer:social;;;event21=1,;footer:social;;;event20=1","eVar16":"footer:social","eVar17":"footer:social:"+url,"prop17":"footer:social:facebook:facebook","eVar42":"footer","prop42":"footer","prop67":"social","eVar67":"social","linkName":"footer-social-link","prop68":"facebook","eVar68":"facebook"}'></a>
            </li>

            <!-- INSTAGRAM -->
            <li>
                <a href="https://instagram.com/eonlineau" class="social-link social-link--instagram"
                    target="_blank" data-omniture='trackElement|{"trackEvents":"event20,event21","products":";footer:social;;;event21=1,;footer:social;;;event20=1","eVar16":"footer:social","eVar17":"footer:social:"+url,"prop17":"footer:social:instagram:instagram","eVar42":"footer","prop42":"footer","prop67":"social","eVar67":"social","linkName":"footer-social-link","prop68":"instagram","eVar68":"instagram"}'></a>
            </li>

            <!-- PINTEREST -->
            
                

                
                    <li>
                        <a href="https://www.pinterest.com/eentertainment/pins/follow/?guid=WtyoZwkH3aD_-0" class="social-link social-link--pinterest"
                            target="_blank" data-omniture='trackElement|{"trackEvents":"event20,event21","products":";footer:social;;;event21=1,;footer:social;;;event20=1","eVar16":"footer:social","eVar17":"footer:social:"+url,"prop17":"footer:social:pinterest:pinterest","eVar42":"footer","prop42":"footer","prop67":"social","eVar67":"social","linkName":"footer-social-link","prop68":"pinterest","eVar68":"pinterest"}'></a>
                    </li>
                
            


            <!-- TWITTER -->
            <li>
                <a href="https://twitter.com/EOnlineAU" class="social-link social-link--twitter" target="_blank"
                    data-omniture='trackElement|{"trackEvents":"event20,event21","products":";footer:social;;;event21=1,;footer:social;;;event20=1","eVar16":"footer:social","eVar17":"footer:social:"+url,"prop17":"footer:social:twitter:twitter","eVar42":"footer","prop42":"footer","prop67":"social","eVar67":"social","linkName":"footer-social-link","prop68":"twitter","eVar68":"twitter"}'></a>
            </li>

            <!-- TUMBLR -->
            
                

                

                
                    <li>
                        <a href="https://enews.tumblr.com" class="social-link social-link--tumblr"
                            target="_blank" data-omniture='trackElement|{"trackEvents":"event20,event21","products":";footer:social;;;event21=1,;footer:social;;;event20=1","eVar16":"footer:social","eVar17":"footer:social:"+url,"prop17":"footer:social:tumblr:tumblr","eVar42":"footer","prop42":"footer","prop67":"social","eVar67":"social","linkName":"footer-social-link","prop68":"tumblr","eVar68":"tumblr"}'></a>
                    </li>
                
            

            <!-- SNAPCHAT -->
            
                

                

                
                    <li>
                        <a href="https://www.snapchat.com/add/e_news" class="social-link social-link--snapchat"
                            target="_blank" data-omniture='trackElement|{"trackEvents":"event20,event21","products":";footer:social;;;event21=1,;footer:social;;;event20=1","eVar16":"footer:social","eVar17":"footer:social:"+url,"prop17":"footer:social:snapchat:snapchat","eVar42":"footer","prop42":"footer","prop67":"social","eVar67":"social","linkName":"footer-social-link","prop68":"snapchat","eVar68":"snapchat"}'></a>
                    </li>
                
            


            <!-- GOOGLEPLUS -->
            
                

                
                    <!-- no googleplus -->
                
            
        </ul>
    </div>

    


    
    
        


    
    <ul class="footer__links footer__links--first footer__links--last c-grid l-spacing--md">
        <li><a href="/au/about" target="_blank" data-omniture='trackElement|{"linkName":"nav:footer:about","products":"eVar16=\"nav\""},"prop17":"eVar16=\"nav\"","eVar17":"eVar16=\"nav\"","eVar16":"frontdoor-modules"}'>About Us</a></li>
        <li><a href="/au/affiliates" target="_blank" data-omniture='trackElement|{"linkName":"nav:footer:get-e","products":"eVar16=\"nav\""},"prop17":"eVar16=\"nav\"","eVar17":"eVar16=\"nav\"","eVar16":"frontdoor-modules"}'>Get E!</a></li>
        <li><a href="mailto:enewsau@nbcuni.com" target="_blank" data-omniture='trackElement|{"linkName":"nav:footer:contact","products":"eVar16=\"nav\""},"prop17":"eVar16=\"nav\"","eVar17":"eVar16=\"nav\"","eVar16":"frontdoor-modules"}'>Contact Us</a></li>
        <li><a href="/au/sitemap" target="_blank" data-omniture='trackElement|{"linkName":"nav:footer:sitemap","products":"eVar16=\"nav\""},"prop17":"eVar16=\"nav\"","eVar17":"eVar16=\"nav\"","eVar16":"frontdoor-modules"}'>Site Map</a></li>
        <li><a href="/au/news/mobile" target="_blank" data-omniture='trackElement|{"linkName":"nav:footer:apps","products":"eVar16=\"nav\""},"prop17":"eVar16=\"nav\"","eVar17":"eVar16=\"nav\"","eVar16":"frontdoor-modules"}'>Apps</a></li>
        <li><a href="/au/shows/schedule" target="_blank"  data-omniture='trackElement|{"linkName":"nav:footer:shows_schedule","products":"eVar16=\"nav\""},"prop17":"eVar16=\"nav\"","eVar17":"eVar16=\"nav\"","eVar16":"frontdoor-modules"}'>Show Schedule</a></li>
        <li><a href="mailto:Peter.Harrison@nbcuni.com,Giselle.Gonzales@nbcuni.com" target="_blank" data-omniture='trackElement|{"linkName":"nav:footer:Advertise","products":"eVar16=\"nav\""},"prop17":"eVar16=\"nav\"","eVar17":"eVar16=\"nav\"","eVar16":"frontdoor-modules"}'>Advertise</a></li>
        <li><a href="https://www.nbcuniversal.com/privacy/cookies" target="_blank" data-omniture='trackElement|{"linkName":"nav:footer:cookie-policy","products":"eVar16=\"nav\""},"prop17":"eVar16=\"nav\"","eVar17":"eVar16=\"nav\"","eVar16":"frontdoor-modules"}'>Cookie Policy</a></li>
        <li><a href="http://syndication.eonline.com/syndication/feeds/rssfeeds/topstories.xml?edition=au" target="_blank" data-omniture='trackElement|{"linkName":"nav:footer:rss","products":"eVar16=\"nav\""},"prop17":"eVar16=\"nav\"","eVar17":"eVar16=\"nav\"","eVar16":"frontdoor-modules"}'>RSS Feeds</a></li>
        <li><a href="https://www.eonline.com/au/shows/peoples_choice_awards" target="_blank">People's Choice</a></li>
		<li>|</li>
		<li>
			<a href="/peoples_choice_awards/faq" target="_blank">
				People's Choice FAQ
			</a>
		</li>		
    </ul>
    
    
    
    
    
    
    
    


    

    <div class="footer__tagline-wrap">
        <div class="footer__tagline">
            
            <a href="/au/" class="footer__eonline-logo footer__eonline-logo--au"
                data-omniture='trackElement|{"linkName":"nav:footer:main","products":"eVar16=\"nav\""},"prop17":"eVar16=\"nav\"","eVar17":"eVar16=\"nav\"","eVar16":"frontdoor-modules"}'></a>
            E! Online - Your source for entertainment news, celebrities, celeb news, and&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;<br>celebrity gossip. Check out the hottest fashion, photos, movies and TV shows!
        </div>
    </div>

    
    

    <div class="footer__bottom footer__bottom--au">
        
            <a href="https://www.nbcuniversal.com/privacy/" target="_blank" class="footer__bottom-link"
                data-omniture='trackElement|{"linkName":"nav:footer:privacy-policy","products":"eVar16=\"nav\""},"prop17":"eVar16=\"nav\"","eVar17":"eVar16=\"nav\"","eVar16":"frontdoor-modules"}'
                rel="nofollow">
                New Privacy Policy</a> | <a href="/au/terms"
                target="_blank" class="footer__bottom-link" data-omniture='trackElement|{"linkName":"nav:footer:terms-of-use","products":"eVar16=\"nav\""},"prop17":"eVar16=\"nav\"","eVar17":"eVar16=\"nav\"","eVar16":"frontdoor-modules"}'
                rel="nofollow">
                Terms of Service</a>
            
                
                
                    |
                
            
            
        
        &copy; 2018 E! Entertainment Television, LLC.  A
        Division of NBCUniversal.
        All rights reserved.
        
    </div>

</div> <!-- footer -->
			</div>

			



<div style="display: none;">

	<script type="text/javascript">

		
			
			
			

				
					s.prop7="eonline.com/news/992882/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist";
				
					s.prop9="arrow,tv,top-stories,entertainment,apple-news";
				
					s.prop63="news";
				
					s.prop65="tv";
				
					s.prop1="tv-scoop";
				
					s.prop2="tv-scoop:news";
				
					s.prop3="tv-scoop:news:tv";
				
					s.prop48="tv-scoop:news:tv:articles";
				
					s.prop66="tv-scoop:news:tv:articles";
				
					s.pageName="tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist";
				
					s.events="event42";
				
					s.linkTrackEvents="event42";
				
					s.eVar1="news";
				
					s.prop14="arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist";
				
					s.prop15="articles";
				
					s.prop62="detail";
				
					s.prop19="992882";
				
					s.prop72="2018-12-03";
				
					s.products=";text-block-photo-with-text;;;event42=1,;text-block-call-to-action;;;event42=1,;text-block-text-only;;;event42=1,";
				
					s.prop58="lauren piester";
				

				
				
				if(typeof wa.page === 'object' && typeof wa.page.advertiser !== 'undefined' && wa.page.advertiser != '') {
				    s.eVar76 = wa.page.advertiser;
				}

			
		

	</script>
	
	
	
		
			
				
				
					
					<script type="text/javascript">/************* DO NOT ALTER ANYTHING BELOW THIS LINE ! **************/
					var s_code=s.t();if(s_code)document.write(s_code)//--></script>
					<script language="JavaScript" type="text/javascript"><!--
					if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'\!-'+'-')
					//--></script><noscript><img src="https://comcastentertainmentgroup.112.2o7.net/b/ss/comcastegegeonlinecom/1/H.24.3--NS/0"
					height="1" width="1" border="0" alt="" /></noscript><!--/DO NOT REMOVE/-->
					<!-- End SiteCatalyst code version: H.24.3. -->
					<!-- END: SiteCatalyst Code -->
				
			
		
		
	

	
	
		
		
		
		
		
			
		
		
		
	

	<!-- GA (au) -->
	<script type="text/javascript">
		var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
		document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
	</script>
	<script type="text/javascript">
		var pageTracker = _gat._getTracker("UA-852400-10");
		pageTracker._initData();
		
			pageTracker._trackPageview();
		
	</script>

</div>

			

		</div>

		



















	



	
	
	
		
		
	


<!-- Facebook Pixel Code -->
	<script>
    var fbstarttime = new Date();
		!function(f,b,e,v,n,t,s) {
			if (f.fbq)
				return;
			n = f.fbq = function() {
				n.callMethod?
				n.callMethod.apply(n,arguments):n.queue.push(arguments)
			};
			if (!f._fbq)
				f._fbq = n;
			n.push = n;
			n.loaded =! 0;
			n.version = '2.0';
			n.queue = [];
			t = b.createElement(e);
			t.async =! 0;
			t.src = v;
			s = b.getElementsByTagName(e)[0];
			s.parentNode.insertBefore(t, s);
		}(window, document, 'script', 'https://connect.facebook.net/en_US/fbevents.js');

		fbq('init', '1611373942516879');
		fbq('track', 'PageView');

    var fbendtime = new Date();
	</script>

	
	<noscript>
		<img
			height="1" width="1"
			src="https://www.facebook.com/tr?id=1611373942516879&ev=PageView&noscript=1" />
	</noscript>
<!-- End Facebook Pixel Code -->



<script type=application/ld+json>
	{
		"@context": "http://schema.org", 
		"@type": "WebPage", 
		"@id": "http://m.eonline.com/au/news/992885/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist", 
		"potentialAction": 
		{ "@type": "ViewAction", "target": "android-app://com.rhythmnewmedia.android.e/http/m.eonline.com/au/news/992885/arrow-s-mystery-deepens-with-katherine-mcnamara-s-arrival-huge-green-arrow-twist"}
	}
</script>







	
	
	


<script type='text/javascript'>
	var _sf_async_config={};

	/** CONFIGURATION START **/
	_sf_async_config.uid = 53221; 
	_sf_async_config.domain = 'eonline.com';
	_sf_async_config.useCanonical = true;
	_sf_async_config.sections = 'news,au,International';
	_sf_async_config.authors = 'Lauren Piester';
	_sf_async_config.videoPageGroups = true;
	/** CONFIGURATION END **/

	(function(){
		function loadChartbeat() {
			window._sf_endpt=(new Date()).getTime();
			var e = document.createElement('script');
			e.setAttribute('language', 'javascript');
			e.setAttribute('type', 'text/javascript');
			e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
			document.body.appendChild(e);
		}
		var oldonload = window.onload;
		window.onload = (typeof window.onload != 'function') ?
			loadChartbeat : function() { oldonload(); loadChartbeat(); };
	})();
</script>









	
	
	
		<script type='text/javascript' src='//s.swiftypecdn.com/cc/h4ocSnndrY_rzP5tFFZx.js'></script>
	
	
	
	
	
	
	
	
	
	
	




<script src="/dist/js/bottom.resources.3.46e172c4e6ab2c783d24.js"></script>






<div class="js-gdpr-notice gdpr-notice">

	<div class="gdpr-notice-wrapper clear">
		
		<p class="gdpr-notice-text">
			
				
				
				
					We and our partners use cookies on this site to improve our service, perform analytics, personalize advertising, measure advertising performance, and remember website preferences. By using the site, you consent to these cookies. For more information on cookies including how to manage your consent visit our <a href="https://www.nbcuniversal.com/privacy/cookies" target="_blank">Cookie Policy</a>.
				
			
		</p>

		<button class="gdpr-notice-btn js-gdpr-notice-btn">
			
				
				
				
					Continue
				
			
		</button>

	</div>

</div>










	









<div class="js-onee-dialog onee-dialog">
	<div class="onee-dialog-content">
		
		<div class="onee-dialog-header clear">
			<div class="js-onee-flag hidden" data-geoEdition="us">
				<div class="flag-sprite-map new-edition_us"></div>
				<h5>U.S.</h5>
			</div>
			<div class="js-onee-flag hidden" data-geoEdition="ca">
				<div class="flag-sprite-map new-edition_ca"></div>
				<h5>CA</h5>
			</div>
			<div class="js-onee-flag hidden" data-geoEdition="uk">
				<div class="flag-sprite-map new-edition_uk"></div>
				<h5>U.K.</h5>
			</div>
			<div class="js-onee-flag hidden" data-geoEdition="au">
				<div class="flag-sprite-map new-edition_au"></div>
				<h5>AU</h5>
			</div>
			<div class="js-onee-flag hidden" data-geoEdition="ap">
				<div class="flag-sprite-map new-edition_ap"></div>
				<h5>Asia</h5>
			</div>
			<div class="js-onee-flag hidden" data-geoEdition="de">
				<div class="flag-sprite-map new-edition_de"></div>
				<h5>DE</h5>
			</div>
			<div class="js-onee-flag hidden" data-geoEdition="fr">
				<div class="flag-sprite-map new-edition_fr"></div>
				<h5>FR</h5>
			</div>
		</div>

		
			
			
				<div class="js-onee-text hidden" data-geoEdition="us">
					<h3>E! Is Everywhere</h3>
					<p>This content is available customized for our international audience. Would you like to view this in our US edition?</p>
				</div>
				<div class="js-onee-text hidden" data-geoEdition="ca">
					<h3>E! Is Everywhere</h3>
					<p>This content is available customized for our international audience. Would you like to view this in our Canadian edition?</p>
				</div>
				<div class="js-onee-text hidden" data-geoEdition="uk">
					<h3>E! Is Everywhere</h3>
					<p>This content is available customized for our international audience. Would you like to view this in our UK edition?</p>
				</div>
				<div class="js-onee-text hidden" data-geoEdition="au">
					<h3>E! Is Everywhere</h3>
					<p>This content is available customized for our international audience. Would you like to view this in our Australian edition?</p>
				</div>
				<div class="js-onee-text hidden" data-geoEdition="ap">
					<h3>E! Is Everywhere</h3>
					<p>This content is available customized for our international audience. Would you like to view this in our Asia edition?</p>
				</div>
				<div class="js-onee-text hidden" data-geoEdition="de">
					<h3>E! ist &uuml;berall</h3>
					<p>Dieser Inhalt ist f&uuml;r internationale Besucher verf&uuml;gbar. M&ouml;chtest du ihn in der deutschen Version anschauen?</p>
				</div>
				<div class="js-onee-text hidden" data-geoEdition="de-en">
					<h3>E! Is Everywhere</h3>
					<p>This content is available customized for our international audience. Would you like to view this in our German edition?</p>
				</div>
				<div class="js-onee-text hidden" data-geoEdition="fr">
					<h3>E! est partout</h3>
					<p>Une version adapt&eacute;e de ce contenu est disponible pour notre public international. Souhaitez-vous voir &ccedil;a dans notre &eacute;dition fran&ccedil;aise ?</p>
				</div>
				<div class="js-onee-text hidden" data-geoEdition="fr-en">
					<h3>E! Is Everywhere</h3>
					<p>This content is available customized for our international audience. Would you like to view this in our French edition?</p>
				</div>
				<div class="js-onee-text hidden" data-geoEdition="ar">
					<h3>E! está en todos lados</h3>
					<p>Nuestro contenido está disponible y personalizado para nuestra audiencia internacional. ¿Te gustaría verlo en la edición en español?</p>
				</div>
				<div class="js-onee-text hidden" data-geoEdition="co">
					<h3>E! está en todos lados</h3>
					<p>Nuestro contenido está disponible y personalizado para nuestra audiencia internacional. ¿Te gustaría verlo en la edición en español?</p>
				</div>
				<div class="js-onee-text hidden" data-geoEdition="mx">
					<h3>E! está en todos lados</h3>
					<p>Nuestro contenido está disponible y personalizado para nuestra audiencia internacional. ¿Te gustaría verlo en la edición en español?</p>
				</div>
				<div class="js-onee-text hidden" data-geoEdition="ve">
					<h3>E! está en todos lados</h3>
					<p>Nuestro contenido está disponible y personalizado para nuestra audiencia internacional. ¿Te gustaría verlo en la edición en español?</p>
				</div>
			
		
        
        
        
        
        
        
        
        
        
        
        
            
        
            
        
            
		<div class="onee-dialog-btns js-onee-dialog-btns clear">
			<div class="js-onee-btns hidden" data-geoEdition="us">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="ca">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/ca">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="uk">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/uk">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="au">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/au">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="ap">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/ap">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="de">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/de">Ja !</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>Nein, danke.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="de-en">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/de">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="fr">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/fr">Oui!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>Non, merci.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="fr-en">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/fr">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="br">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/br">Sim</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>Não</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="br-en">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/br">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="la">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="http://la.eonline.com">&iexcl;Si!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, gracias.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="la-en">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="http://la.eonline.com">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="ar">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/ar">Si</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="ar-en">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/ar">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="co">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/co">Si</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="co-en">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/co">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="mx">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/mx">Si</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="mx-en">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/mx">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="ve">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/ve">Si</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="ve-en">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/ve">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:tv-scoop:news:tv:articles:992885:arrows-mystery-deepens-with-katherine-mcnamaras-arrival--huge-green-arrow-twist", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
		</div>
		<div class="onee-dialog-footer">
			
				
				
					<a href="#" class="js-onee-dialog-translate hidden" data-geoEdition="de" data-translateToEdition="de-en">Translate to English</a>
					<a href="#" class="js-onee-dialog-translate hidden" data-geoEdition="fr" data-translateToEdition="fr-en">Translate to English</a>
					<br>
				
			
			<a href="/de/impressum" target="_blank" class="js-onee-dialog-impressum hidden" data-geoEdition="de">Impressum</a>
		</div>
	</div>
</div>





	<script type="text/javascript">_satellite.pageBottom();</script>


		








	

	

	

	

	

	

	

	











	<script type="text/javascript">
		window._taboola = window._taboola || [];
		_taboola.push({flush: true});
	</script>

	</body>
</html>
