












	
	
	
	
	
	
	
	
	
	
	
	
		
	



	
	
		
	








<!DOCTYPE html>
<html lang="en" class="ap">

	<head>
		<!--  -->

		
			
		

		
		<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<meta charset="utf-8">



	<title>The Masked Singer: The Best Season 3 Guesses | E! News</title>
	<meta name="description" content="Get a look at all of the costumes for season three of The Masked Singer as we take a look at the best guesses so far">

	
	
		<link rel="alternate" href="https://www.eonline.com/news/1119020/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="x-default" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/news/1119020/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-us" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/news/1119020/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/au/news/1119023/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-au" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/uk/news/1119022/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-gb" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ca/news/1119021/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-ca" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-bd" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-bt" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-bn" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-kh" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-cn" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-tl" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-fj" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-hk" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-jp" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-kr" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-in" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-id" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-la" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-my" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-mv" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-mo" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-mn" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-mm" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-np" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-pw" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-pg" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-ph" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-sg" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-lk" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-tw" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-th" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-vu" class="js-onee-hreflang">
	
		<link rel="alternate" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses" hreflang="en-vn" class="js-onee-hreflang">
	
	
	<meta name="one.e.enabled" data-edition="ap" class="js-onee-meta-tag">
	
	
	<link rel="shortcut icon" href="/resources/images/misc/favicon.ico">
	<link rel="icon" href="/resources/images/misc/eonline_favicon_trans.png">
	<link rel="apple-touch-icon" href="/apple-touch-icon.png">
	
	
	<meta name="google-site-verification" content="PrhEi7w612RQMIMh7TQkkEOxkApb2TCbAZBdqITWU3U"> 
	<meta name="msvalidate.01" content="564B986CE3CECCAE84779191BEC6B755"> 
	
	
	
<meta property="og:title" content="The Masked Singer: The Best Season 3 Guesses">
<meta property="og:type" content="article">
<meta property="og:url" content="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses">
<meta property="og:image" content="https://akns-images.eonline.com/eol_images/Entire_Site/2020021/rs_600x600-200121114650-600x600.the-masked-singer-turtle-lp.12120.jpg?fit=around|600:467&crop=600:467;center,top&output-quality=90">
<meta property="og:site_name" content="E! Online">
<meta property="og:description" content="Get a look at all of the costumes for season three of The Masked Singer as we take a look at the best guesses so far">
<meta property="og:locale" content="en_AP">




	<meta property="og:image:width" content="600">
	<meta property="og:image:height" content="467">
	<meta property="article:published_time" content="Mon Feb 03 14:20:59 PST 2020">
	<meta property="article:modified_time" content="Mon Feb 03 14:20:57 PST 2020">
	<meta property="article:opinion" content="false">
	<meta property="article:content_tier" content="free">



	


<meta property="fb:admins" content="10101649">
<meta property="fb:pages" content="89033370735">
<meta property="fb:pages" content="199268073449270">
<meta property="fb:pages" content="1387539234854280">

	<meta property="fb:app_id" content="195662528604">




	<meta name="twitter:card" content="summary_large_image">
	<meta name="twitter:site" content="https://twitter.com/eonline">
	<meta name="twitter:title" content="The Masked Singer: The Best Season 3 Guesses">
	<meta name="twitter:description" content="Get a look at all of the costumes for season three of The Masked Singer as we take a look at the best guesses so far">
	<meta name="twitter:image" content="https://akns-images.eonline.com/eol_images/Entire_Site/2020021/rs_600x600-200121114650-600x600.the-masked-singer-turtle-lp.12120.jpg?fit=around|600:300&crop=600:300;center,top&output-quality=90">
	<meta name="twitter:url" content="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses">


	





	
	<meta class="swiftype" name="category" data-type="enum" content="News">
	<meta class="swiftype" name="publication_date" data-type="date" content="2020-02-03T14:20:59 PST">
	<meta class="swiftype" name="title" data-type="string" content="The Masked Singer Begins Again: See All the Season 3 Contestants and the Best Guesses">
	<meta class="swiftype" name="image" data-type="enum" content="https://akns-images.eonline.com/eol_images/Entire_Site/2020021/rs_600x600-200121114650-600x600.the-masked-singer-turtle-lp.12120.jpg">
	
		<meta class="swiftype" name="tag" data-type="string" content="The Masked Singer">
	
		<meta class="swiftype" name="tag" data-type="string" content="TV">
	
		<meta class="swiftype" name="tag" data-type="string" content="Top Stories">
	
		<meta class="swiftype" name="tag" data-type="string" content="Entertainment">
	
		<meta class="swiftype" name="tag" data-type="string" content="Apple News">
	
		<meta class="swiftype" name="tag" data-type="string" content="Celebrities">
	
		<meta class="swiftype" name="tag" data-type="string" content="VG">
	


	



	<meta name="sailthru.contenttype" content="news">
	<meta name="sailthru.image.full" content="https://akns-images.eonline.com/eol_images/Entire_Site/2020021/rs_600x600-200121114650-600x600.the-masked-singer-turtle-lp.12120.jpg?fit=around|300:300&crop=300:300;center,top&output-quality=90">



	<meta name="sailthru.cid" content="1119024">



	<meta name="sailthru.ed.cid" content="ap_1119024">


	
	
	
		<link rel="canonical" href="https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses">
	

	
		
		
	

	
		
		
	

	
		<link rel="alternate" media="only screen and (max-width: 640px)" href="https://m.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses">
	

	
	
		<link rel="amphtml" href="https://m.eonline.com/ap/amp/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses">
	
	
	
	
		<meta name="googlebot-news" content="index,follow">
	
	
	

	

	

	
		<meta name="news_keywords" content="the masked singer, fox, lil wayne, jenny mccarthy, ">
	

	
	<meta name="tp:PreferredRuntimes" content="universal,html5,flash">
	<meta name="tp:PreferredFormats" content="MPEG4,M3U">

	
	<meta name="google-site-verification" content="jOadQCDbZTkKw5sn27yXszjIb9c3PdMPHENN92uPWy8" />

	
	
		<meta name="taboola.title" content="The Masked Singer Begins Again: See All the Season 3 Contestants and the Best Guesses">
	



		
		

		
		










<script src="/dist/js/vendor.3aa3637a5dee7a358ef3.js"></script>
<script src="/dist/js/head.resources.1.b7a5b110ed32d395ff80.js"></script>


	
	




<script>
	// Static MPS values
	var mpsopts = {'updatecorrelator':true, 'host': "mps.nbcuni.com" };

	// Define Specific MPS values for Page
	var mpscall={
	    'site': "eonline-web",
	    'path': "", // unique path value for page GETS DYNAMICALLY SET BY MPS 
	    'cag[locale]': decodeURIComponent(document.cookie.replace(new RegExp("(?:(?:^|.*;)\\s*adEdition\\s*\\=\\s*([^;]*).*$)|^.*$"), "$1")) || "us", // akamai cookie || default us
	};

	
		
		
			mpscall['is_content'] = 1; // 1 for articles & 

			
				mpscall["content_id"] = '1119024';
						
		
	
	
		mpscall['cag[topics]'] = "top stories|tv|the masked singer|entertainment|apple news|celebrities|vg"; //pipe delim list of all topics
	
	

		
			
			
				mpscall['cag[primary]'] = "top stories"; //primary topic

				
					mpscall['cat'] = "topics|"+mpscall['cag[primary]']+"|news detail";
				
			
			
	
	
	
		mpscall['type'] = 'news detail';
		
        
	
	
	var mps=mps||{};mps._ext=mps._ext||{};mps._adsheld=[];mps._queue=mps._queue||{};mps._queue.mpsloaded=mps._queue.mpsloaded||[];mps._queue.mpsinit=mps._queue.mpsinit||[];mps._queue.gptloaded=mps._queue.gptloaded||[];mps._queue.adload=mps._queue.adload||[];mps._queue.adclone=mps._queue.adclone||[];mps._queue.adview=mps._queue.adview||[];mps._queue.refreshads=mps._queue.refreshads||[];mps.__timer=Date.now();mps.__intcode="v2";if(typeof mps.getAd!="function")mps.getAd=function(adunit){if(typeof adunit!="string")return false;var slotid="mps-getad-"+adunit.replace(/\W/g,"");if(!mps._ext||!mps._ext.loaded){mps._queue.gptloaded.push(function(){typeof mps._gptfirst=="function"&&mps._gptfirst(adunit,slotid);mps.insertAd("#"+slotid,adunit)});mps._adsheld.push(adunit)}return'<div id="'+slotid+'" class="mps-wrapper" data-mps-fill-slot="'+adunit+'"></div>'};(function(){head=document.head||document.getElementsByTagName("head")[0],mpsload=document.createElement("script");mpsload.src="//"+mpsopts.host+"/fetch/ext/load-"+mpscall.site+".js?nowrite=2";mpsload.id="mps-load";head.insertBefore(mpsload,head.firstChild)})();
</script>











<script type="text/javascript">
	var wa = wa || {
		site: {
			edition: {
				content: "ap",
				geo: jQuery.cookie("geoEdition"),
				ad: jQuery.cookie("adEdition")
			},
			experience: 'desktop'
		}
	};
</script>



	
	
		
		
			
				
					<script src="//assets.adobedtm.com/40c5e2c2fd7b89c305112b620e8ba76af1e548fe/satelliteLib-90d98ff908836445257862774a980980cee4ecb6.js"></script>
				
				
			
		

	











	
	
			<script>
	

	var _comscore = _comscore || [];
	_comscore.push({ c1: "2", c2: "6035083", c3: "", c4: "", cs_ucfr: "0" });
	(function(){ 
		var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
		s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
		el.parentNode.insertBefore(s, el); 
	})(); 
</script>
<noscript>
	<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035083&c3=&c4=&c5=&c6=&c15=&cv=2.0&cj=1" />
</noscript>








<link type="text/css" rel="stylesheet" href="https://fonts.googleapis.com/css?family=Lato:400,400i,700,700i,900,900i|Oswald:400,300,700">


	
	
		<link type="text/css" rel="stylesheet" href="/dist/css/head.resources.1.b7ea8d02e9922277e581.css">
		<link type="text/css" rel="stylesheet" href="/dist/css/all.widgets.3.4481bcab39b1ddad09fe.css">
	















	
	
	
	
	
	
	
			
		
				
				




<script>
var eol_fw_ad_policy = "policy%3D";
var eol_fw_ad_policy_num = "";
</script>


<script id="js-evideo" data-edomain="www.eonline.com" data-edition="ap" data-port="80"
 data-embed-code="&lt;/&gt;&nbsp;Get Embed Code" data-to-copy="CTRL-C or CMD-C to copy, then press Enter"
 data-copy="COPY"></script>







		
		





    <meta name="viewport" content="width=1280">


<link type="text/css" rel="stylesheet" href="/dist/css/article.detail.9.097edd0c602d1d643db4.css" />

<script>
    (function($){
        /* Set the framework type as soon as we can so that there isn't a "jump"
           going from fw lrg 1280 to 980, since this jsp loads in the <head> */
        var winWidth = $(window).width();
        if(winWidth <= 1280 && 'true' === "false"){
            $('html').addClass('fw--md');
        }
    })(jQuery);
</script>


<script>
(function($){
    if(navigator.userAgent.match(/iPad/i) == null) {
		$("html").addClass("no-touch");
	} else {$("html").addClass("touch");}

})(jQuery);
</script>




<meta name="sailthru.date" content="2020-02-03 14:20:59" />

<meta name="sailthru.title" content="The Masked Singer Begins Again: See All the Season 3 Contestants and the Best Guesses" />
<meta name="sailthru.tags" content="the_masked_singer,tv,top_stories,entertainment,apple_news,celebrities,vg" />
<meta name="sailthru.edition" content="ap" />


<meta itemprop="datePublished" content="2020-02-03T14:20:59Z" />
<meta itemprop="dateModified" content="2020-02-03T14:20:57Z" />


<meta property="article:tag" content="the_masked_singer,tv,top_stories,entertainment,apple_news,celebrities,vg" />

<script type="text/javascript" src="https://pdk.theplatform.com/next/pdk/tpPdk.js"></script>

<script type="text/javascript">
(function() { 
    function loadHorizon() { 
        var s = document.createElement('script'); 
        s.type = 'text/javascript'; 
        s.async = true; 
        s.src = location.protocol + '//ak.sail-horizon.com/horizon/v1.js'; 
        var x = document.getElementsByTagName('script')[0]; 
        x.parentNode.insertBefore(s, x); 
    } 
    loadHorizon(); 
    var oldOnLoad = window.onload; 
    window.onload = function() { 
        if (typeof oldOnLoad === 'function') { 
            oldOnLoad(); 
        } 
        Sailthru.setup({ 
            domain: 'horizon.eonline.com' 
        }); 
    }; 
})(); 
</script> 

<script id="adp-js" type="text/javascript" src="/dist/js/article.detail.9.e5b40ba8377b4e699f04.js" data-v-gallery="true"></script>

	</head>

	
	<body 
		id="detail" 
		class=" eol news news edition_ap js-onee-script "
		data-edition="ap" 
		data-isEditionOptInEnabled="true" 
		data-editionOptInType="default"
		data-pagetype="NEWS_DETAIL"
		data-airship-modal="false"
		data-airship-modal-second="true"
		data-airship-user=" "
		data-skin="">

		<div class="leaderboard" data-hook="leaderboard">
			
				<div class="nav__adbanner" data-hook="navadbanner">

























	










	




			
	
		<div  id="top-banner"  data-slot="topbanner"   data-render-ad="instant" class="mps-ad" ></div>
	



	<script>
		if (typeof mps === 'object') {
			console.log('eolMpsAd Instant', 'topbanner');
			
			mps._queue=mps._queue||{}; mps._queue.gptloaded=mps._queue.gptloaded||[];
			mps._queue.gptloaded.push(function() {
				mps.insertAd(mps._select('#top-banner'), 'topbanner', '');
			});
		}
	</script>


</div>
			
			<div class="lp_wrap">
				










	
		
	
	






	
	
	
	
	
	
	
	
	
		
	


<div class="nav__wrapper " id="nav__wrapper">
	<div class="nav" id="HHeader" data-nav-info='{"edition" : "ap"}' data-hook="main-nav">
		<div class="nav__extender nav__extender--left">
			<div class="extender-bkg"></div>
		</div>
		<div class="nav__extender nav__extender--right"></div>
		<div class="nav__nav-base">
			<div class="nav__first-group">
				
				
				
				
				
				
				
				
				
				
				
				
					
					
					
						
							
							
								
							
							
							
						
					
				
				<a class="nav__logo-link nav__logo-link--default nav__logo-link--ap-branding"
				 href="/ap/" data-omniture='trackNavElement|{"products":";top-navigation:e-logo;;;event21=1","eVar16":"top-navigation:e-logo","eVar17":"top-navigation:e-logo:/","prop17":"top-navigation:e-logo:nav-item:e-logo","eVar42":"navigation","prop42":"navigation"}'></a>
			</div>
		
			<div class="nav__second-group">
				<div class="nav__middle-slot">
					
				</div>

				<ul class="nav__menu-main">
					
					
						
						

						<li class="nav__menu-item">
							
								
									<a href="/ap/news" data-omniture='trackNavElement|{ "products" : ";top-navigation:latest-news;;;event21=1", "eVar16" : "top-navigation:latest-news", "eVar17" : "top-navigation:latest-news:/ap/news", "prop17" : "top-navigation:latest-news:nav-item:latest-news", "eVar42" : "navigation", "prop42" : "navigation" }'>Latest News</a>
								
								
							
							
							
						</li>
					
						
						

						<li class="nav__menu-item">
							
								
									<a href="https://www.eonline.com/ap/news/2020_oscars" data-omniture='trackNavElement|{ "products" : ";top-navigation:oscars;;;event21=1", "eVar16" : "top-navigation:oscars", "eVar17" : "top-navigation:oscars:https://www.eonline.com/ap/news/2020_oscars", "prop17" : "top-navigation:oscars:nav-item:oscars", "eVar42" : "navigation", "prop42" : "navigation" }'>OSCARS</a>
								
								
							
							
							
						</li>
					
						
						

						<li class="nav__menu-item">
							
								
									<a href="/ap/photos" data-omniture='trackNavElement|{ "products" : ";top-navigation:photos;;;event21=1", "eVar16" : "top-navigation:photos", "eVar17" : "top-navigation:photos:/ap/photos", "prop17" : "top-navigation:photos:nav-item:photos", "eVar42" : "navigation", "prop42" : "navigation" }'>PHOTOS</a>
								
								
							
							
							
						</li>
					
						
						

						<li class="nav__menu-item">
							
								
									<a href="https://www.eonline.com/ap/news/kobe_bryant" data-omniture='trackNavElement|{ "products" : ";top-navigation:kobe-bryant;;;event21=1", "eVar16" : "top-navigation:kobe-bryant", "eVar17" : "top-navigation:kobe-bryant:https://www.eonline.com/ap/news/kobe_bryant", "prop17" : "top-navigation:kobe-bryant:nav-item:kobe-bryant", "eVar42" : "navigation", "prop42" : "navigation" }'>KOBE BRYANT</a>
								
								
							
							
							
						</li>
					
						
						

						<li class="nav__menu-item">
							
								
									<a href="https://www.eonline.com/ap/news/fashion_week" data-omniture='trackNavElement|{ "products" : ";top-navigation:fashion-week;;;event21=1", "eVar16" : "top-navigation:fashion-week", "eVar17" : "top-navigation:fashion-week:https://www.eonline.com/ap/news/fashion_week", "prop17" : "top-navigation:fashion-week:nav-item:fashion-week", "eVar42" : "navigation", "prop42" : "navigation" }'>FASHION WEEK</a>
								
								
							
							
							
						</li>
					
						
						

						<li class="nav__menu-item">
							
								
									<a href="/ap/news/royals" data-omniture='trackNavElement|{ "products" : ";top-navigation:meghan--harry;;;event21=1", "eVar16" : "top-navigation:meghan--harry", "eVar17" : "top-navigation:meghan--harry:/ap/news/royals", "prop17" : "top-navigation:meghan--harry:nav-item:meghan--harry", "eVar42" : "navigation", "prop42" : "navigation" }'>MEGHAN & HARRY</a>
								
								
							
							
							
						</li>
					
						
						

						<li class="nav__menu-item">
							
								
									<a href="/ap/news/kardashians" data-omniture='trackNavElement|{ "products" : ";top-navigation:kardashians;;;event21=1", "eVar16" : "top-navigation:kardashians", "eVar17" : "top-navigation:kardashians:/ap/news/kardashians", "prop17" : "top-navigation:kardashians:nav-item:kardashians", "eVar42" : "navigation", "prop42" : "navigation" }'>Kardashians</a>
								
								
							
							
							
						</li>
					
						
						

						<li class="nav__menu-item">
							
								
									<a href="/ap/videos" data-omniture='trackNavElement|{ "products" : ";top-navigation:videos;;;event21=1", "eVar16" : "top-navigation:videos", "eVar17" : "top-navigation:videos:/ap/videos", "prop17" : "top-navigation:videos:nav-item:videos", "eVar42" : "navigation", "prop42" : "navigation" }'>Videos</a>
								
								
							
							
							
								<ul class="nav__subnav">
									
										<li>
											

											<a href="/ap/shows/e_news" data-omniture='trackNavElement|{ "products" : ";top-navigation:e-news;;;event21=1", "eVar16" : "top-navigation:e-news", "eVar17" : "top-navigation:e-news:/ap/shows/e_news", "prop17" : "top-navigation:e-news:nav-item:e-news", "eVar42" : "navigation", "prop42" : "navigation" }'>E! NEWS</a>
										</li>
									
										<li>
											

											<a href="/ap/news/k-popping" data-omniture='trackNavElement|{ "products" : ";top-navigation:k-popping;;;event21=1", "eVar16" : "top-navigation:k-popping", "eVar17" : "top-navigation:k-popping:/ap/news/k-popping", "prop17" : "top-navigation:k-popping:nav-item:k-popping", "eVar42" : "navigation", "prop42" : "navigation" }'>K-POPPING</a>
										</li>
									
										<li>
											

											<a href="/ap/news/thirstday" data-omniture='trackNavElement|{ "products" : ";top-navigation:thirstday;;;event21=1", "eVar16" : "top-navigation:thirstday", "eVar17" : "top-navigation:thirstday:/ap/news/thirstday", "prop17" : "top-navigation:thirstday:nav-item:thirstday", "eVar42" : "navigation", "prop42" : "navigation" }'>#THIRSTDAY</a>
										</li>
									
										<li>
											

											<a href="/ap/news/beaute_with_yvette" data-omniture='trackNavElement|{ "products" : ";top-navigation:beaute;;;event21=1", "eVar16" : "top-navigation:beaute", "eVar17" : "top-navigation:beaute:/ap/news/beaute_with_yvette", "prop17" : "top-navigation:beaute:nav-item:beaute", "eVar42" : "navigation", "prop42" : "navigation" }'>BEAUT&Eacute;</a>
										</li>
									
										<li>
											

											<a href="/ap/news/famously_fit_with_mond " data-omniture='trackNavElement|{ "products" : ";top-navigation:famously-fit;;;event21=1", "eVar16" : "top-navigation:famously-fit", "eVar17" : "top-navigation:famously-fit:/ap/news/famously_fit_with_mond ", "prop17" : "top-navigation:famously-fit:nav-item:famously-fit", "eVar42" : "navigation", "prop42" : "navigation" }'>FAMOUSLY FIT</a>
										</li>
									
										<li>
											

											<a href="/ap/news/mond-days" data-omniture='trackNavElement|{ "products" : ";top-navigation:mond-days;;;event21=1", "eVar16" : "top-navigation:mond-days", "eVar17" : "top-navigation:mond-days:/ap/news/mond-days", "prop17" : "top-navigation:mond-days:nav-item:mond-days", "eVar42" : "navigation", "prop42" : "navigation" }'>MOND DAYS</a>
										</li>
									
										<li>
											

											<a href="/ap/news/social_studies_club" data-omniture='trackNavElement|{ "products" : ";top-navigation:social-studies-club;;;event21=1", "eVar16" : "top-navigation:social-studies-club", "eVar17" : "top-navigation:social-studies-club:/ap/news/social_studies_club", "prop17" : "top-navigation:social-studies-club:nav-item:social-studies-club", "eVar42" : "navigation", "prop42" : "navigation" }'>SOCIAL STUDIES CLUB</a>
										</li>
									
										<li>
											

											<a href="/ap/news/sweet_life" data-omniture='trackNavElement|{ "products" : ";top-navigation:sweet-life;;;event21=1", "eVar16" : "top-navigation:sweet-life", "eVar17" : "top-navigation:sweet-life:/ap/news/sweet_life", "prop17" : "top-navigation:sweet-life:nav-item:sweet-life", "eVar42" : "navigation", "prop42" : "navigation" }'>SWEET LIFE</a>
										</li>
									
										<li>
											

											<a href="/ap/news/what_the_fad" data-omniture='trackNavElement|{ "products" : ";top-navigation:what-the-fad;;;event21=1", "eVar16" : "top-navigation:what-the-fad", "eVar17" : "top-navigation:what-the-fad:/ap/news/what_the_fad", "prop17" : "top-navigation:what-the-fad:nav-item:what-the-fad", "eVar42" : "navigation", "prop42" : "navigation" }'>WHAT THE FAD?!</a>
										</li>
									
								</ul>
							
						</li>
					
				</ul>
			</div>
			<div class="nav__third-group">
				<ul class="nav__menu-intl">
					<li><a class="nav__menu-intl-current" href="javascript:void(0)" data-link="unbind-omniture">ap</a></li>
					<li class="nav__menu-intl-menuitem"><a class="nav__au" href="/au" data-omniture='trackElement|{"products":";top-navigation:edition;;;event21=1","eVar16":"top-navigation:edition","eVar17":"top-navigation:edition:/au","prop17":"top-navigation:edition:edition-link:australia","eVar42":"navigation","prop42":"navigation"}'>Australia</a></li>
					<li class="nav__menu-intl-menuitem"><a class="nav__ap" href="/ap" data-omniture='trackElement|{"products":";top-navigation:edition;;;event21=1","eVar16":"top-navigation:edition","eVar17":"top-navigation:edition:/ap","prop17":"top-navigation:edition:edition-link:asia","eVar42":"navigation","prop42":"navigation"}'>Asia</a></li>
					<li class="nav__menu-intl-menuitem"><a class="nav__de" href="/de" data-omniture='trackElement|{"products":";top-navigation:edition;;;event21=1","eVar16":"top-navigation:edition","eVar17":"top-navigation:edition:/de","prop17":"top-navigation:edition:edition-link:germany","eVar42":"navigation","prop42":"navigation"}'>Germany</a></li>
					<li class="nav__menu-intl-menuitem"><a class="nav__fr" href="/fr" data-omniture='trackElement|{"products":";top-navigation:edition;;;event21=1","eVar16":"top-navigation:edition","eVar17":"top-navigation:edition:/fr","prop17":"top-navigation:edition:edition-link:france","eVar42":"navigation","prop42":"navigation"}'>France</a></li>
					<li class="nav__menu-intl-menuitem"><a class="nav__uk" href="/uk" data-omniture='trackElement|{"products":";top-navigation:edition;;;event21=1","eVar16":"top-navigation:edition","eVar17":"top-navigation:edition:/uk","prop17":"top-navigation:edition:edition-link:uk","eVar42":"navigation","prop42":"navigation"}'>UK</a></li>
					<li class="nav__menu-intl-menuitem"><a class="nav__ca" href="/ca" data-omniture='trackElement|{"products":";top-navigation:edition;;;event21=1","eVar16":"top-navigation:edition","eVar17":"top-navigation:edition:/ca","prop17":"top-navigation:edition:edition-link:canada","eVar42":"navigation","prop42":"navigation"}'>Canada</a></li>
					<li class="nav__menu-intl-menuitem"><a class="nav__us" href="/" data-omniture='trackElement|{"products":";top-navigation:edition;;;event21=1","eVar16":"top-navigation:edition","eVar17":"top-navigation:edition:/","prop17":"top-navigation:edition:edition-link:usa","eVar42":"navigation","prop42":"navigation"}'>USA</a></li>

					
						
							<li class="nav__menu-intl-menuitem"><a class="nav__mx" href="/mx" data-omniture='trackElement|{"products":";top-navigation:edition;;;event21=1","eVar16":"top-navigation:edition","eVar17":"top-navigation:edition:/mx","prop17":"top-navigation:edition:edition-link:mexico","eVar42":"navigation","prop42":"navigation"}'
								 rel="noopener">Mexico</a></li>
							<li class="nav__menu-intl-menuitem"><a class="nav__br" href="/br" data-omniture='trackElement|{"products":";top-navigation:edition;;;event21=1","eVar16":"top-navigation:edition","eVar17":"top-navigation:edition:/br","prop17":"top-navigation:edition:edition-link:brazil","eVar42":"navigation","prop42":"navigation"}'>Brazil</a></li>
							<li class="nav__menu-intl-menuitem"><a class="nav__ar" href="/ar" data-omniture='trackElement|{"products":";top-navigation:edition;;;event21=1","eVar16":"top-navigation:edition","eVar17":"top-navigation:edition:/ar","prop17":"top-navigation:edition:edition-link:argentina","eVar42":"navigation","prop42":"navigation"}'>Argentina</a></li>
							<li class="nav__menu-intl-menuitem"><a class="nav__co" href="/co" data-omniture='trackElement|{"products":";top-navigation:edition;;;event21=1","eVar16":"top-navigation:edition","eVar17":"top-navigation:edition:/co","prop17":"top-navigation:edition:edition-link:colombia","eVar42":"navigation","prop42":"navigation"}'>Colombia</a></li>
							<li class="nav__menu-intl-menuitem"><a class="nav__ve" href="/ve" data-omniture='trackElement|{"products":";top-navigation:edition;;;event21=1","eVar16":"top-navigation:edition","eVar17":"top-navigation:edition:/ve","prop17":"top-navigation:edition:edition-link:venezuela","eVar42":"navigation","prop42":"navigation"}'>Venezuela</a></li>
						
						
					
				</ul>
				<div class="nav__search">
					
					<label for="queryly_toggle">
						<div class="nav__search-button js-nav__search-button queryly_search_button" data-link="unbind-omniture"
							data-queryly-enabled="true">
						</div>
					</label>
					<div class="nav__search-form">
						<form class="nav__form" action="/ap/search">
							<label class="nav__form-label">
								Press Enter to Search</label>
							<input class="nav__form-textarea" type="text" value="" name="query" autocomplete="on" />
							<input class="nav__form-submit" type="submit" value="" />
						</form>
					</div>
				</div>
			</div>
		</div>
	</div>
</div>
			</div>
			
				




				



						
		</div>
		

		<div class="eol-outerwrapper" data-hook="eol-outerwrapper"> 

			

			
			<div id="page" class="lp_wrap">
				

























		
	
















	
		
	



<script type="text/javascript">
 var tpLogLevel = "error";

 function fw_config(){
 	return evideo.getFreewheelConfig('article', '');
 }

	/* ===| *BEGIN* SET OMNITURE NATIVE CONTENT VARIABLE |=== */
	/*
		- execute very early, before tracking.jsp (s.tl function call)
		- execute after wa object is created
	*/
	// avoid wa object undefined error on pages in which wa is possibly not defined
	var wa = wa || {};

	wa.page = wa.page || {};
	wa.page.content = wa.page.content || {};
	

	// check if page has branded content enabled
	if (false) {
		wa.page.content.native = "native";
	} else {
		wa.page.content.native = "not-native";
	}
	/* ====| *END* SET OMNITURE NATIVE CONTENT VARIABLE |==== */

	eolMpsAd.isSkinBleed = true;  // for mps skin ad
</script>


 














	




	



	
	
	
		
		
	



	
	
		
			
			
				 
			
		
	



<div id="article-detail" class="article-detail" 
		data-swiftype-index="true" 
		data-swiftype-name="body" 
		data-swiftype-type="text"
		data-twitter-title="The Masked Singer: The Best Season 3 Guesses"
		data-video-dock-suppressed="false">

	









	
	
	
		
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	



	<script async src="//static.vilynx.com/gallery/vpg.5.2.0.min.js" 
			data-publickey="f2636e04b5a097ebb0a967769a3d22a1" 
			data-redirecttext="Watch in"
			data-redirect="true"
			data-analytics="true"></script>
	


	
	
	

	
	

	<div class="article-meta  ">
		
		
		




		<h1 class="article__title">
			<i>The Masked Singer</i> Begins Again: See All the Season 3 Contestants and the Best Guesses
		</h1>
		
		
		





<div class="presented-by" data-swiftype-index="false">
	<div
		id="presented-by__bar"
		class="presented-by__bar"
		data-has-byline-override="false"
		data-has-adkeyword="false"
	>
		<ul class="l-grid presented-by--spacing">
			
			
				
				
					
					<li class="presented-by--v-centered">
						<div class="presented-by__textbox">
							<div class="presented-by__default-byline-element">By</div>
							<div class="presented-by__default-byline-element"><div class="e-logo--xs"></div>
						<div class="presented-by__default-byline-element">&</div>
						</div>					
					</li>

				
			
						

		</ul>
	</div>
	<div class="presented-by__divider"></div>
</div>

		
		
		








<p class="entry-meta" data-swiftype-index="false">
	<span class="entry-meta__author">
		<span class="u-lc">by</span>
		

		
			
				
					<a href="/authors/lauren-piester">Lauren Piester</a>
				
				
			
			
		
	</span>
	
	|
	
		
		
			<span class="entry-meta__time">Mon., 3 Feb. 2020 2:20 PM</span>
		
		
	
</p>

		
		

		















	
	































	




	
	








<div id="article-detail-social-icons" class="cs-container" data-swiftype-index="false" data-omniture-info='{ "pagename" : "news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "widgetType" : "share:social", "pageType" : "text-blocks" }'>
	<ul class="cs-list clear">
		
			<li class="cs-fb cs-item">
				<div class="cs-share"  >
					<span class="cs-sharetext">Share</span>
				</div>
				
			</li>
		
		
		<li  class="cs-ts cs-item">
			<div  class="cs-share" >
				<span class="cs-sharetext">Tweet</span>
			</div>
			
		</li>
			
		
		
			<li id="email-bttn-article-detail-social-icons" class="cs-email cs-item">
				<div  class="cs-share email" >
					<span class="cs-sharetext">Email</span>
				</div>
			</li>
		
		
		
	</ul>
	
	
		<div id="preload_hovers_here-article-detail-social-icons" style="display: none;">
		   <img src="/resources/customSocialBar/images/Facebook_hover.png" width="1" height="1" />
		   <img src="/resources/customSocialBar/images/twitter.png" width="1" height="1" />
		   <img src="/resources/customSocialBar/images/email_hover.png" width="1" height="1" />
		   
		</div>
	
</div>

	
	
		
		
		
		
		
		
			
		
	

	<script type="text/javascript">
		customSocialBar.globalSettings = {
				"twitterAccount" : "enews",
				"i8nProductionDomain" : "https://www.eonline.com",
				"edition" : "ap",
				"embedTop" : 40,
				"embedLeft" : 0
		}
	</script>












<script>
	//this is a var b/c we could reuse this articleDetailConfigJSON in the bottom social bar (but n change the containerID)
	(function(){
		
		var articleDetailConfigJSON = {
			"containerID" : "article-detail-social-icons",
			"tweetText" : "The Masked Singer: The Best Season 3 Guesses",
			"getCountsOnLoad": true,
			"articleId": 1119024
		};

		var articleDetailSocialBar = new customSocialBar(articleDetailConfigJSON);
		customSocialOmnitureHelper(articleDetailSocialBar); //activate default omniture
	})();

</script>

	</div>

	
	
	
	

	
	
	
	

	
		
	
		
	
		
	
		
	
		
	
		
	

	
		
		
		
			
			
		

		
		
			
			
				
				
				
			
		

		
		
		

		
		
			














	

	<div id="photo-txt-0" class="post-content text-block clearfix post-content--groupedn-txt " data-hook="scrollable-block" >

		
		
			<div class="column post-content__image--left post-content__image" data-swiftype-index="false">

				

				
					







		    
<div class="article_pinterest"></div>

<style>
.article_pinterest{background: url('/resources/images/pinterest/pinterest.png');height:51px;width:51px;}
.article_pinterest:hover{cursor:pointer;background:url('/resources/images/pinterest/pinterest_hover.png');height:51px;width:51px;}
</style>

<script> 
	var edition = 'ap';
	var encodedShareURL = encodeURI('https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses');
	var imgSrc =  encodeURIComponent('https://akns-images.eonline.com/eol_images/Entire_Site/202013/rs_634x729-200203063443-634-masked-singer-s-3-ch-020320.jpg?fit=inside|900:auto&output-quality=90');
	var articleTitle = encodeURIComponent(jQuery(".entry_container .sub-headline").text());
	var imageTitle = encodeURIComponent("The Masked Singer Season 3");
	var imageCaption = encodeURIComponent("The Masked Singer Season 3");

	var titleJoin;
			
	function sharePinterest(){
	   	if (articleTitle.length > 1 && imageTitle.length > 1) {
			if (edition == 'de') {
				titleJoin = '%20%2D%20';
			} else if (edition == 'fr') {
				titleJoin = '%20de%20';
			} else {
				titleJoin = '%20from%20';
			}
		} else {
			titleJoin = "";
		}
		window.open('https://pinterest.com/pin/create/button/?url=' +  encodedShareURL + '&media=' + imgSrc + '&description=' + articleTitle + '%0A%0A' + imageCaption,  '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=253,width=750');
	}
	
	jQuery(".article_pinterest").click(function(){
				sharePinterest();
		});
	
</script>
				

				<img class="image--full" src="https://akns-images.eonline.com/eol_images/Entire_Site/202013/rs_634x729-200203063443-634-masked-singer-s-3-ch-020320.jpg?fit=inside|900:auto&output-quality=90" title="The Masked Singer Season 3" alt="The Masked Singer Season 3" />

				
					<p class="image__credits">Fox</p>
				

			</div>

		

		
		
		
				
				
				
					<section data-textblock-tracking="text-block-photo-text"><p><em>The Masked Singer</em> is fully back for round three, and that means it's officially time for all of us to start those Google searches.&nbsp;</p><p><a href="https://www.eonline.com/news/1118692/the-masked-singer-returns-with-super-bowl-special-and-unmasks-the-robot" target="_blank">Last night</a>, we met the six singers who will be competing over the first few weeks of the season, and we even saw the unmasking of the biggest star the show has had to date. It turned out that Lil Wayne was under the Robot mask, and that reveal shocked the entire panel, including guest panelist Jamie Foxx who had been guessing Steve-O earlier on in the night.&nbsp;</p><p>We also saw performances from White Tiger, Turtle, Miss Monster, Kangaroo, and Llama and got clues for each of them. There are a couple whose identity we feel pretty sure of, and a couple who have stumped not only us, but the majority of the internet, from what we could tell.&nbsp;</p></section>
				
		
	</div>


		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		
		
		
		
		

		
		
		

		
	
		
		
		
			
			
		

		
		
			
			
				
				
				
			
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
			

	
	

	
	
	

	
		
		
		
			
		
		
	

	<div id="cta-1" class="post-content  cta  clearfix" data-hook="scrollable-block"  data-swiftype-index="false">

		
		

			

			
			

			<div  
				class="column cta__thumb " 
				 data-url="/news/1118692/the-masked-singer-returns-with-super-bowl-special-and-unmasks-the-robot" >
				
				
					
						
						
					

					<img class="image--full" src="https://akns-images.eonline.com/eol_images/Entire_Site/202012/rs_600x600-200202195148-600x600.the-masked-singer-robot-lp.2220.jpg?fit=inside|192:192&output-quality=90" />

				
			</div>
		

		<div class="column cta__text " data-textblock-tracking="text-block-cta" data-swiftype-index="false">
			
				<h2 class="cta__title">Read</h2>
			
			<p><strong><a href="https://www.eonline.com/us/news/1118692/the-masked-singer-returns-with-super-bowl-special-and-unmasks-the-robot" target="_blank"><em>The Masked Singer</em> Returns With Super Bowl Special and Unmasks the Robot</a></strong></p>
		</div>

		
			<a class="link--full-takeover" href="/news/1118692/the-masked-singer-returns-with-super-bowl-special-and-unmasks-the-robot" data-omniture='trackElement|{"linkTrackEvents":"event43","products":";text-block-cta;;;event43","eVar16":"text-block-cta","eVar17":"text-block-cta:/news/1118692/the-masked-singer-returns-with-super-bowl-special-and-unmasks-the-robot","prop17":"text-block-cta:hyperlink:the-masked-singer-returns-with-super-bowl-special-and-unmasks-the-robot","prop42":"text-blocks","eVar42":"text-blocks","linkName":"text-block-cta","appendLinkTrackVars":"prop9,prop14,prop15,prop62,prop72,eVar15,eVar62,eVar72,list1,"}'></a>
		
	</div>
	
		
		
		
		
		
		

		
		
		

		
			<div class="athena__wrapper column cols--md-s" data-hook="scrollable-block">
				


















	














	







			
	
		<div  data-slot="athena1"   data-render-ad="onload" class="mps-ad mps-centered" data-repeatable="true"></div>
	





			</div>
		
	
		
		
		
			
			
		

		
		
			
			
				
				
				
			
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		
		
		
		
		

		
		
			



<div id="text-2" class="post-content text-block clearfix post-content--groupedn-txt " data-hook="scrollable-block" >

	
	
	
			
			
			
				<section data-textblock-tracking="text-block-text-only" data-swiftype-index="false"><p>Our only hope is that Lil Wayne's reveal didn't just set us all up for a season of disappointment as the others are unmasked.&nbsp;</p><p>While we have yet to see performances from most of the singers, we have now gotten a look at all of the costumes, including three new ones: T-Rex, Elephant, and something called a Night Angel.&nbsp;</p><p>It's as terrifying as it sounds, and you can get a look at it below!&nbsp;</p></section>
			
	
</div>

		
		

		
	
		
		
		

		
		
			
			
				
				
				
			
		

		
		
			

<div data-hook="scrollable-block" class="post-content "  data-textblock-tracking="vertical-gallery">
	
				
				
																
				
					
					
						
						
						

							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
																	
							
							
							
							
						
						 

					
					
					
						

						
						
						

						
							
							
							
						

						
							
							
							
						

						<div class="post-content__image post-content__image--centered" style="max-width:877px">

							<div id="photo-1069600" class="v-gallery__post ">
								<img src=" " class="image--full lazy-load__img js-lazy-load" style="max-width:877px" data-width="877" data-height="650" data-src="https://akns-images.eonline.com/eol_images/Entire_Site/202013/rs_1024x759-200203141255-1024-Lil-Wayne-The-Masked-Singer.jpg?fit=inside|900:650&output-quality=90" data-id="1069600" alt="Lil Wayne, the Masked Singe"
								/>
							</div>

							<p class="image__credits image__credits--right">Getty Images/Greg Gayne/FOX</p>

							
								<h3 class="v-gallery__title">
									The Robot: Lil Wayne
								</h3>
							
							
							
								<div class="v-gallery__text">
									<p>The first reveal of the season was the biggest star yet: Lil Wayne!</p><p>The Robot had lots of science references, including a periodic table, since he's had so many records go platinum, but the clues were sort of irrelevant. It's hard to mistake that voice.&nbsp;</p>
								</div>
							
						</div>
							
					

		

	
				
				
																
				
					
					
						
						
						

							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
																	
							
							
							
							
						
						 

					
					
					
						

						
						
						

						

						
							
							
							
						

						<div class="post-content__image post-content__image--centered" style="max-width:565px">

							<div id="photo-1065438" class="v-gallery__post ">
								<img src=" " class="image--full lazy-load__img js-lazy-load" style="max-width:565px" data-width="565" data-height="650" data-src="https://akns-images.eonline.com/eol_images/Entire_Site/2020022/rs_634x729-200122065725-634-3-masked-singer-s-3-ch-012220.jpg?fit=inside|900:650&output-quality=90" data-id="1065438" alt="The Masked Singer Season 3"
								/>
							</div>

							<p class="image__credits image__credits--right">Fox</p>

							
								<h3 class="v-gallery__title">
									The White Tiger
								</h3>
							
							
							
								<div class="v-gallery__text">
									<p>White Tiger's not really a singer, at least based on his Vanilla Ice impression. He's clearly huge and likely an athlete, and is a "clam shucking" champion, which makes you think of New England.&nbsp;</p><p>Guest panelist Jamie Foxx guessed <strong>Rob Gronkowski</strong>&nbsp;and he seemed incredibly sure. Gronk is from upstate NY, he's a football champ, and "Ice Ice Baby" seems exactly like a song he'd sing.</p>
								</div>
							
						</div>
							
					

		

	
				
				
																
				
					
					
						
						
						

							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
																	
							
							
							
							
						
						 

					
					
					
						

						
						
						

						

						
							
							
							
						

						<div class="post-content__image post-content__image--centered" style="max-width:565px">

							<div id="photo-1065434" class="v-gallery__post ">
								<img src=" " class="image--full lazy-load__img js-lazy-load" style="max-width:565px" data-width="565" data-height="650" data-src="https://akns-images.eonline.com/eol_images/Entire_Site/2020022/rs_634x729-200122065723-634-4-masked-singer-s-3-ch-012220.jpg?fit=inside|900:650&output-quality=90" data-id="1065434" alt="The Masked Singer Season 3"
								/>
							</div>

							<p class="image__credits image__credits--right">Fox</p>

							
								<h3 class="v-gallery__title">
									The Turtle
								</h3>
							
							
							
								<div class="v-gallery__text">
									<p>He's definitely got some singing chops, and he took things "step by step" while others crashed and burned. He also grills burgers, and he likes to surf OR he won a Teen Choice Award.&nbsp;</p><p>The panel guessed Zac Efron and&nbsp;Jenny McCarthy even guessed her husband, <strong>Donnie Wahlberg</strong> (because of the burgers), but the internet seems absolutely sure it's <strong>Jesse McCartney,&nbsp;</strong>who has multiple Teen Choice surfboards and was in the boyband Dream Street. Could you imagine if it's Zefron though??&nbsp;</p>
								</div>
							
						</div>
							
					

		
			<div class="post-content post-content--interstitial clear" data-block-type="ad" >
				<div class="v-gallery__interstitial clearfix">
					<div class="v-gallery__interstitial-ad" data-hook="v-gallery-interstitial">
						


















	




















			
	
		<div  data-slot="galleryrepeat"   data-render-ad="onload" class="mps-ad" data-repeatable="true"></div>
	





					</div>
					<p class="v-gallery__continue-text">
						Article continues below
					</p>
				</div>
			</div> 
		

	
				
				
																
				
					
					
						
						
						

							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
																	
							
							
							
							
						
						 

					
					
					
						

						
						
						

						

						
							
							
							
						

						<div class="post-content__image post-content__image--centered" style="max-width:565px">

							<div id="photo-1065436" class="v-gallery__post ">
								<img src=" " class="image--full lazy-load__img js-lazy-load" style="max-width:565px" data-width="565" data-height="650" data-src="https://akns-images.eonline.com/eol_images/Entire_Site/2020022/rs_634x729-200122065724-634-5-masked-singer-s-3-ch-012220.jpg?fit=inside|900:650&output-quality=90" data-id="1065436" alt="The Masked Singer Season 3"
								/>
							</div>

							<p class="image__credits image__credits--right">Fox</p>

							
								<h3 class="v-gallery__title">
									The Llama
								</h3>
							
							
							
								<div class="v-gallery__text">
									<p>The Llama appears to be a comedian on the radio (23.3 The Wool), and he really likes Seattle. He's a fan of the movie <em>Ghost</em>?&nbsp;</p><p>The panel decided it couldn't be Howard Stern and guessed David Spade and Joel McHale. The internet immediately went Kelsey Grammar, because of the Seattle of it all,&nbsp;Danny Bonaduce, and Drew Carey. Though David Spade did play a man who turned into a llama in <em>The Emperor's New Groove</em>...</p>
								</div>
							
						</div>
							
					

		

	
				
				
																
				
					
					
						
						
						

							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
																	
							
							
							
							
						
						 

					
					
					
						

						
						
						

						

						
							
							
							
						

						<div class="post-content__image post-content__image--centered" style="max-width:565px">

							<div id="photo-1065439" class="v-gallery__post ">
								<img src=" " class="image--full lazy-load__img js-lazy-load" style="max-width:565px" data-width="565" data-height="650" data-src="https://akns-images.eonline.com/eol_images/Entire_Site/2020022/rs_634x729-200122065725-634-2-masked-singer-s-3-ch-012220.jpg?fit=inside|900:650&output-quality=90" data-id="1065439" alt="The Masked Singer Season 3"
								/>
							</div>

							<p class="image__credits image__credits--right">Fox</p>

							
								<h3 class="v-gallery__title">
									Miss Monster
								</h3>
							
							
							
								<div class="v-gallery__text">
									<p>Miss Monster's got a big ol' crush on the Monster/T-Pain, and she seems to have struggled with having to look and act a certain way in public.&nbsp;</p><p>She sounds exactly like Chaka Khan, though some on the internet also hear some Tina Turner. She is not Dolly Parton, as Ken Jeong guessed. Sorry Ken.&nbsp;</p>
								</div>
							
						</div>
							
					

		

	
				
				
																
				
					
					
						
						
						

							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
																	
							
							
							
							
						
						 

					
					
					
						

						
						
						

						

						
							
							
							
						

						<div class="post-content__image post-content__image--centered" style="max-width:565px">

							<div id="photo-1065432" class="v-gallery__post ">
								<img src=" " class="image--full lazy-load__img js-lazy-load" style="max-width:565px" data-width="565" data-height="650" data-src="https://akns-images.eonline.com/eol_images/Entire_Site/2020022/rs_634x729-200122065722-634-6-masked-singer-s-3-ch-012220.jpg?fit=inside|900:650&output-quality=90" data-id="1065432" alt="The Masked Singer Season 3"
								/>
							</div>

							<p class="image__credits image__credits--right">Fox</p>

							
								<h3 class="v-gallery__title">
									The Kangaroo
								</h3>
							
							
							
								<div class="v-gallery__text">
									<p>The Kangaroo is a tough one! She lost someone close to her, "by her own admission" found herself in the spotlight for the wrong reasons, and now she wants to bounce back. She references her bullies and being a survivor.&nbsp;</p><p>A lot of people immediately went for Jordyn Woods, who lost her father recently and then found herself in an unfortunate spotlight, but that voice does NOT sound like Jordyn to us. Not even a little bit.&nbsp;</p>
								</div>
							
						</div>
							
					

		
			<div class="post-content post-content--interstitial clear" data-block-type="ad" >
				<div class="v-gallery__interstitial clearfix">
					<div class="v-gallery__interstitial-ad" data-hook="v-gallery-interstitial">
						


















	




















			
	
		<div  data-slot="galleryrepeat"   data-render-ad="onload" class="mps-ad" data-repeatable="true"></div>
	





					</div>
					<p class="v-gallery__continue-text">
						Article continues below
					</p>
				</div>
			</div> 
		

	
				
				
																
				
					
					
						
						
						

							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
																	
							
							
							
							
						
						 

					
					
					
						

						
						
						

						

						
							
							
							
						

						<div class="post-content__image post-content__image--centered" style="max-width:565px">

							<div id="photo-1069369" class="v-gallery__post ">
								<img src=" " class="image--full lazy-load__img js-lazy-load" style="max-width:565px" data-width="565" data-height="650" data-src="https://akns-images.eonline.com/eol_images/Entire_Site/202013/rs_634x729-200203063443-634-2-masked-singer-s-3-ch-020320.jpg?fit=inside|900:650&output-quality=90" data-id="1069369" alt="The Masked Singer Season 3"
								/>
							</div>

							<p class="image__credits image__credits--right">Fox</p>

							
								<h3 class="v-gallery__title">
									The T-Rex
								</h3>
							
							
							
						</div>
							
					

		

	
				
				
																
				
					
					
						
						
						

							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
																	
							
							
							
							
						
						 

					
					
					
						

						
						
						

						

						
							
							
							
						

						<div class="post-content__image post-content__image--centered" style="max-width:565px">

							<div id="photo-1069366" class="v-gallery__post ">
								<img src=" " class="image--full lazy-load__img js-lazy-load" style="max-width:565px" data-width="565" data-height="650" data-src="https://akns-images.eonline.com/eol_images/Entire_Site/202013/rs_634x729-200203063442-634-3-masked-singer-s-3-ch-020320.jpg?fit=inside|900:650&output-quality=90" data-id="1069366" alt="The Masked Singer Season 3"
								/>
							</div>

							<p class="image__credits image__credits--right">Fox</p>

							
								<h3 class="v-gallery__title">
									The Elephant
								</h3>
							
							
							
						</div>
							
					

		

	
				
				
																
				
					
					
						
						
						

							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
																	
							
							
							
							
						
						 

					
					
					
						

						
						
						

						

						
							
							
							
						

						<div class="post-content__image post-content__image--centered" style="max-width:565px">

							<div id="photo-1069370" class="v-gallery__post ">
								<img src=" " class="image--full lazy-load__img js-lazy-load" style="max-width:565px" data-width="565" data-height="650" data-src="https://akns-images.eonline.com/eol_images/Entire_Site/202013/rs_634x729-200203063443-634-masked-singer-s-3-ch-020320.jpg?fit=inside|900:650&output-quality=90" data-id="1069370" alt="The Masked Singer Season 3"
								/>
							</div>

							<p class="image__credits image__credits--right">Fox</p>

							
								<h3 class="v-gallery__title">
									Night Angel
								</h3>
							
							
							
						</div>
							
					

		
			<div class="post-content post-content--interstitial clear" data-block-type="ad" >
				<div class="v-gallery__interstitial clearfix">
					<div class="v-gallery__interstitial-ad" data-hook="v-gallery-interstitial">
						


















	




















			
	
		<div  data-slot="galleryrepeat"   data-render-ad="onload" class="mps-ad" data-repeatable="true"></div>
	





					</div>
					<p class="v-gallery__continue-text">
						Article continues below
					</p>
				</div>
			</div> 
		

	
				
				
																
				
					
					
						
						
						

							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
																	
							
							
							
							
						
						 

					
					
					
						

						
						
						

						

						
							
							
							
						

						<div class="post-content__image post-content__image--centered" style="max-width:565px">

							<div id="photo-1068890" class="v-gallery__post ">
								<img src=" " class="image--full lazy-load__img js-lazy-load" style="max-width:565px" data-width="565" data-height="650" data-src="https://akns-images.eonline.com/eol_images/Entire_Site/2020031/rs_634x729-200131114609-634-32-rhino-ch-013120.jpg?fit=inside|900:650&output-quality=90" data-id="1068890" alt="The Masked Singer Season 3"
								/>
							</div>

							<p class="image__credits image__credits--right">Fox</p>

							
								<h3 class="v-gallery__title">
									The Mouse
								</h3>
							
							
							
						</div>
							
					

		

	
				
				
																
				
					
					
						
						
						

							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
																	
							
							
							
							
						
						 

					
					
					
						

						
						
						

						

						
							
							
							
						

						<div class="post-content__image post-content__image--centered" style="max-width:565px">

							<div id="photo-1068891" class="v-gallery__post ">
								<img src=" " class="image--full lazy-load__img js-lazy-load" style="max-width:565px" data-width="565" data-height="650" data-src="https://akns-images.eonline.com/eol_images/Entire_Site/2020031/rs_634x729-200131114609-634-rhino-ch-013120.jpg?fit=inside|900:650&output-quality=90" data-id="1068891" alt="The Masked Singer Season 3"
								/>
							</div>

							<p class="image__credits image__credits--right">Fox</p>

							
								<h3 class="v-gallery__title">
									The Rhino
								</h3>
							
							
							
						</div>
							
					

		

	
				
				
																
				
					
					
						
						
						

							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
																	
							
							
							
							
						
						 

					
					
					
						

						
						
						

						

						
							
							
							
						

						<div class="post-content__image post-content__image--centered" style="max-width:565px">

							<div id="photo-1068892" class="v-gallery__post ">
								<img src=" " class="image--full lazy-load__img js-lazy-load" style="max-width:565px" data-width="565" data-height="650" data-src="https://akns-images.eonline.com/eol_images/Entire_Site/2020031/rs_634x729-200131114610-634-2-rhino-ch-013120.jpg?fit=inside|900:650&output-quality=90" data-id="1068892" alt="The Masked Singer Season 3"
								/>
							</div>

							<p class="image__credits image__credits--right">Fox</p>

							
								<h3 class="v-gallery__title">
									The Bear
								</h3>
							
							
							
						</div>
							
					

		
			<div class="post-content post-content--interstitial clear" data-block-type="ad" >
				<div class="v-gallery__interstitial clearfix">
					<div class="v-gallery__interstitial-ad" data-hook="v-gallery-interstitial">
						


















	




















			
	
		<div  data-slot="galleryrepeat"   data-render-ad="onload" class="mps-ad" data-repeatable="true"></div>
	





					</div>
					<p class="v-gallery__continue-text">
						Article continues below
					</p>
				</div>
			</div> 
		

	
				
				
																
				
					
					
						
						
						

							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
																	
							
							
							
							
						
						 

					
					
					
						

						
						
						

						

						
							
							
							
						

						<div class="post-content__image post-content__image--centered" style="max-width:565px">

							<div id="photo-1068072" class="v-gallery__post ">
								<img src=" " class="image--full lazy-load__img js-lazy-load" style="max-width:565px" data-width="565" data-height="650" data-src="https://akns-images.eonline.com/eol_images/Entire_Site/2020029/rs_634x729-200129061930-634-34-masked-singer-ch-012920.jpg?fit=inside|900:650&output-quality=90" data-id="1068072" alt="The Masked Singer Season 3"
								/>
							</div>

							<p class="image__credits image__credits--right">Fox</p>

							
								<h3 class="v-gallery__title">
									The Kitty
								</h3>
							
							
							
						</div>
							
					

		

	
				
				
																
				
					
					
						
						
						

							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
																	
							
							
							
							
						
						 

					
					
					
						

						
						
						

						

						
							
							
							
						

						<div class="post-content__image post-content__image--centered" style="max-width:565px">

							<div id="photo-1068071" class="v-gallery__post ">
								<img src=" " class="image--full lazy-load__img js-lazy-load" style="max-width:565px" data-width="565" data-height="650" data-src="https://akns-images.eonline.com/eol_images/Entire_Site/2020029/rs_634x729-200129061929-634-2-masked-singer-ch-012920.jpg?fit=inside|900:650&output-quality=90" data-id="1068071" alt="The Masked Singer Season 3"
								/>
							</div>

							<p class="image__credits image__credits--right">Fox</p>

							
								<h3 class="v-gallery__title">
									The Swan
								</h3>
							
							
							
						</div>
							
					

		

	
				
				
																
				
					
					
						
						
						

							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
																	
							
							
							
							
						
						 

					
					
					
						

						
						
						

						

						
							
							
							
						

						<div class="post-content__image post-content__image--centered" style="max-width:565px">

							<div id="photo-1068074" class="v-gallery__post ">
								<img src=" " class="image--full lazy-load__img js-lazy-load" style="max-width:565px" data-width="565" data-height="650" data-src="https://akns-images.eonline.com/eol_images/Entire_Site/2020029/rs_634x729-200129061930-634-masked-singer-ch-012920.jpg?fit=inside|900:650&output-quality=90" data-id="1068074" alt="The Masked Singer Season 3"
								/>
							</div>

							<p class="image__credits image__credits--right">Fox</p>

							
								<h3 class="v-gallery__title">
									The Taco
								</h3>
							
							
							
						</div>
							
					

		
			<div class="post-content post-content--interstitial clear" data-block-type="ad" >
				<div class="v-gallery__interstitial clearfix">
					<div class="v-gallery__interstitial-ad" data-hook="v-gallery-interstitial">
						


















	




















			
	
		<div  data-slot="galleryrepeat"   data-render-ad="onload" class="mps-ad" data-repeatable="true"></div>
	





					</div>
					<p class="v-gallery__continue-text">
						Article continues below
					</p>
				</div>
			</div> 
		

	
				
				
																
				
					
					
						
						
						

							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
																	
							
							
							
							
						
						 

					
					
					
						

						
						
						

						

						
							
							
							
						

						<div class="post-content__image post-content__image--centered" style="max-width:565px">

							<div id="photo-1065433" class="v-gallery__post ">
								<img src=" " class="image--full lazy-load__img js-lazy-load" style="max-width:565px" data-width="565" data-height="650" data-src="https://akns-images.eonline.com/eol_images/Entire_Site/2020022/rs_634x729-200122065723-634-7-masked-singer-s-3-ch-012220.jpg?fit=inside|900:650&output-quality=90" data-id="1065433" alt="The Masked Singer Season 3"
								/>
							</div>

							<p class="image__credits image__credits--right">Fox</p>

							
								<h3 class="v-gallery__title">
									The Banana
								</h3>
							
							
							
						</div>
							
					

		

	
				
				
																
				
					
					
						
						
						

							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
																	
							
							
							
							
						
						 

					
					
					
						

						
						
						

						

						
							
							
							
						

						<div class="post-content__image post-content__image--centered" style="max-width:565px">

							<div id="photo-1065431" class="v-gallery__post ">
								<img src=" " class="image--full lazy-load__img js-lazy-load" style="max-width:565px" data-width="565" data-height="650" data-src="https://akns-images.eonline.com/eol_images/Entire_Site/2020022/rs_634x729-200122065722-634-8-masked-singer-s-3-ch-012220.jpg?fit=inside|900:650&output-quality=90" data-id="1065431" alt="The Masked Singer Season 3"
								/>
							</div>

							<p class="image__credits image__credits--right">Fox</p>

							
								<h3 class="v-gallery__title">
									The Frog
								</h3>
							
							
							
						</div>
							
					

		

	
				
				
																
				
					
					
						
						
						

							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
							
																	
							
							
							
							
						
						 

					
					
					
						

						
						
						

						

						
							
							
							
						

						<div class="post-content__image post-content__image--centered" style="max-width:565px">

							<div id="photo-1065914" class="v-gallery__post ">
								<img src=" " class="image--full lazy-load__img js-lazy-load" style="max-width:565px" data-width="565" data-height="650" data-src="https://akns-images.eonline.com/eol_images/Entire_Site/2020023/rs_634x729-200123064057-634-masked-singer-ch-012320.jpg?fit=inside|900:650&output-quality=90" data-id="1065914" alt="The Masked Singer Season 3"
								/>
							</div>

							<p class="image__credits image__credits--right">Fox</p>

							
								<h3 class="v-gallery__title">
									The Astronaut
								</h3>
							
							
							
						</div>
							
					

		
			<div class="post-content post-content--interstitial clear" data-block-type="ad" >
				<div class="v-gallery__interstitial clearfix">
					<div class="v-gallery__interstitial-ad" data-hook="v-gallery-interstitial">
						


















	




















			
	
		<div  data-slot="galleryrepeat"   data-render-ad="onload" class="mps-ad" data-repeatable="true"></div>
	





					</div>
					<p class="v-gallery__continue-text">
						Article continues below
					</p>
				</div>
			</div> 
		

	
</div> 

		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		
		
		
		
		

		
		
		

		
	
		
		
		

		
		
			
			
				
				
				
			
		

		
		
		

		
		
		

		
		
		

		
		
			



	<div id="video-int-4" class="video--dock post-content  " data-hook="scrollable-block" data-dock="parent" >
	

	<div data-dock="item">
		<div class="dock__move dock__button dock__button--hidden hidden" data-dock='button' data-hook='dock-move'>move</div>
		<a class="dock__close dock__button dock__button--hidden hidden" data-dock='button' data-hook='dock-close'>close</a>

		<div data-dock='shadow'>
			
			

			<div class="video__container video__container--dock" data-js="video-embed" data-video-id="296259" data-video-scope="video_296259" data-swiftype-index="false" data-autoplay="false">

				<div class="video-loader js-video-loader video-loader--false">
					<div class="video-loader__bar--one"></div>
					<div class="video-loader__bar--two"></div>
					<div class="video-loader__bar--three"></div>
					<div class="video-loader__bar--four"></div>
					<div class="video-loader__bar--five"></div>
				</div>

				<div class="videoEmbedButton embdButton" data-video-id="296259" data-video-scope="video_296259" data-edition="ap" data-videostart-omniture="text-block-video-only">
				</div>

				
				

				

				<script src="https://player.theplatform.com/p/BdHJDC/articledetail/embed/select/media/1BJp9Ku7t_va?form=javascript&feedParams=entries%3Dfalse&instance=video_296259&autoPlay=false&videoScalingMethod=fit&params=policy%3D" type="text/javascript" data-video-id="296259" data-video-scope-id="video_296259"></script>
				<script type="text/javascript">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</script>


				

				
				
				
					
					

				<div data-vilynx-id="296259" class="vilynx_wrapper vilynx_enabled" data-hook="vilynx-video_296259">
					
					<img src="https://eonlinethumbs-a.akamaihd.net/images/155/1023/rcm_20190925_maskedsinger_b_296259_560x315_1608637507559.jpg" 
						class="video__placeholder-img" 
						data-hook="img-video_296259">

					
						<a class="video__placeholder-play" data-hook="play-video_296259" ></a>
					
				</div>

				
			</div>

			<div class="dock__title hidden" data-dock='title'><div class="hidden" data-dock="now-playing"><em>Now Playing</em></div><div data-dock="up-next"><em>Up Next</em></div><div data-dock="title-text">Jenny McCarthy on If Donnie Wahlberg Would Do "Masked Singer"</div></div>
			</div>

		</div>
	</div>





		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		
		
		
		
		

		
		
		

		
			<div class="athena__wrapper column cols--md-s" data-hook="scrollable-block">
				


















	














	







			
	
		<div  data-slot="athena1"   data-render-ad="onload" class="mps-ad mps-centered" data-repeatable="true"></div>
	





			</div>
		
	
		
		
		
			
			
		

		
		
			
			
				
				
				
			
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		

		
		
		
		
		
		
		

		
		
			



<div id="text-5" class="post-content text-block clearfix post-content--groupedn-txt " data-hook="scrollable-block" >

	
	
	
			
			
			
				<section data-textblock-tracking="text-block-text-only" data-swiftype-index="false"><p><em>The Masked Singer</em> airs Wednesdays at 8 p.m. on Fox.</p></section>
			
	
</div>

		
		

		
	

	
	







<div id="rail" class="rail rail--scrollable column--pos-r" data-swiftype-index="false">

	
	<div data-hook="taboola-rail-offset">
		<div id="rail__mps" class="rail__mps-ad"></div>

		
		
		
			

			<section class="trending glossy-widget" 
					data-hook="trending-stories" 
					data-url="https://pf0ggtc38e.execute-api.us-west-2.amazonaws.com/prod"
					data-edition="ap" 
					data-article-count="5" 
					data-tracking-name="trending-stories-right-rail"
					data-async-load-js-webpack="/dist/js/widgets.trending-stories.22.58efe71ed8712b361440.js">
			
			<header class="glossy-header clearfix">
				<h2 class="glossy-header-container">
					<span class="glossy-header--prefix">Trending</span>
					<span class="glossy-header--suffix glossy-header--line">Stories</span>
				</h2>
				<div class="trending__bluebar"></div>
			</header>

				<div class="trending__content">
					
						<div class="trending__top-article-image" data-hook="top-article-image" data-tb-region-item>
							<div class="trending__top-article-image--placeholder">
								<div class="trending-loading-circle-wrapper">
									<div class="loading-circle"></div>
								</div>
							</div>
						</div>
					

					<ul class="trending__list trending__list--image " data-hook="trending-list-first">
						
							<li class="trending__list-item--placeholder trending__list-item--placeholder-title"
							data-tb-region-item>
								<div class="loading-line"></div>
							</li>
						
							<li class="trending__list-item--placeholder "
							data-tb-region-item>
								<div class="loading-line"></div>
							</li>
						
							<li class="trending__list-item--placeholder "
							data-tb-region-item>
								<div class="loading-line"></div>
							</li>
						
							<li class="trending__list-item--placeholder "
							data-tb-region-item>
								<div class="loading-line"></div>
							</li>
						
							<li class="trending__list-item--placeholder "
							data-tb-region-item>
								<div class="loading-line"></div>
							</li>
						
					</ul>

				</div>

			</section>
		
	</div>

	
		

			<div class="taboola-rail" data-hook="taboola-rail">
				<div id="taboola-right-rail-thumbnails"></div>
			</div>

		
		
	
</div>
</div>



	


























 	
		
			<script>
				window._taboola = window._taboola || [];
				
					
					
						_taboola.push({ "article": 'auto' });
					
				
				
				!function (e, f, u, i) {
					if (!document.getElementById(i)){
					e.async = 1;
					e.src = u;
					e.id = i;
					f.parentNode.insertBefore(e, f);
					}
				}(document.createElement('script'),
				document.getElementsByTagName('script')[0],
				'//cdn.taboola.com/libtrc/eonline-network/loader.js',
				'tb_loader_script');
				if(window.performance && typeof window.performance.mark == 'function') {
					window.performance.mark('tbl_ic');
				}

			</script>
		


		
			<div id="taboola-article" class="post-content">
				<div id="taboola-below-article-thumbnails" ></div>
			</div>
		
		
	


	
	








<div class="entry_footer post-content clear" data-swiftype-index="false" >
	
		<div class="categories">
			<span class="categories__label">
				TAGS/
				</span>
			

			
				
			

			

				<a class="categories__link" href="/ap/news/the_masked_singer" title="view all posts in The Masked Singer" rel="category tag" data-omniture="news_detail:category_The Masked Singer">The Masked Singer</a>

				,
			

				<a class="categories__link" href="/ap/news/tv" title="view all posts in TV" rel="category tag" data-omniture="news_detail:category_TV">TV</a>

				,
			

				<a class="categories__link" href="/ap/news/top_stories" title="view all posts in Top Stories" rel="category tag" data-omniture="news_detail:category_Top Stories">Top Stories</a>

				,
			

				<a class="categories__link" href="/ap/news/entertainment" title="view all posts in Entertainment" rel="category tag" data-omniture="news_detail:category_Entertainment">Entertainment</a>

				,
			

				<a class="categories__link" href="/ap/news/apple_news" title="view all posts in Apple News" rel="category tag" data-omniture="news_detail:category_Apple News">Apple News</a>

				,
			

				<a class="categories__link" href="/ap/news/celebrities" title="view all posts in Celebrities" rel="category tag" data-omniture="news_detail:category_Celebrities">Celebrities</a>

				,
			

				<a class="categories__link" href="/ap/news/vg" title="view all posts in VG" rel="category tag" data-omniture="news_detail:category_VG">VG</a>

				
			
		</div>
	
</div>

<script type="text/javascript">
	if ((typeof(gapi) !== 'undefined') && (typeof(gapi.plusone) !== 'undefined') && (typeof(gapi.plusone.go) !== 'undefined')) {
		gapi.plusone.go("blog_roll");
	}
</script>







































			
	
		<div  data-slot="overlay"   data-render-ad="onload" class="mps-ad" ></div>
	











<script type="application/ld+json">
{
	"@context": "http://schema.org",
	"@type": "NewsArticle",
	"mainEntityofPage": {
		"@type": "WebPage",
		"@id": "https://www.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses"
	},
	"keywords": "The Masked Singer, TV, Top Stories, Entertainment, Apple News, Celebrities, VG",
	"headline": "<i>The Masked Singer</i> Begins Again: See All the Season 3 Contestants and the Best Guesses",
	"image": {
		"@type": "ImageObject",
		"url": "https://akns-images.eonline.com/eol_images/Entire_Site/2020021/rs_600x600-200121114650-600x600.the-masked-singer-turtle-lp.12120.jpg?fit=around|700:700&crop=700:700;center,top&output-quality=90",
		"width": 700,
		"height": 700
	},
	"datePublished": "2020-02-03T14:20:59",
	"dateModified": "2020-02-03T14:20:57",
	"author": {
		"@type": "Person",
		"name": "Lauren Piester"
	},
	"publisher": {
		"@type": "Organization",
		"name": "E! News",
		"logo": {
			"@type": "ImageObject",
			"url": "https://akns-images.eonline.com/eol_images/Entire_Site/201709/rs_100x60-170109133805-e-news-amp-logo-black.png",
			"width": 100,
			"height": 60
		}
	},
	"description": "Get a look at all of the costumes for season three of <i>The Masked Singer</i> as we take a look at the best guesses so far"
}
</script>

	



				







    





<div class="footer" data-hook="footer">
    <div class="nav__extender nav__extender--left nav__extender--gray"></div>
    <div class="nav__extender nav__extender--right nav__extender--gray"></div>

    <div class="footer__socials">
        
            
                <!-- no logo -->
            

            
        

        <ul class="footer__social-list l-grid l-spacing--sm">
            <!-- FACEBOOK -->
            <li>
                <a href="https://www.facebook.com/eentertainmentas" class="social-link social-link--facebook"
                    target="_blank" data-omniture='trackElement|{"trackEvents":"event20,event21","products":";footer:social;;;event21=1,;footer:social;;;event20=1","eVar16":"footer:social","eVar17":"footer:social:"+url,"prop17":"footer:social:facebook:facebook","eVar42":"footer","prop42":"footer","prop67":"social","eVar67":"social","linkName":"footer-social-link","prop68":"facebook","eVar68":"facebook"}'></a>
            </li>

            <!-- INSTAGRAM -->
            <li>
                <a href="https://www.instagram.com/eonlineasia/?hl=en" class="social-link social-link--instagram"
                    target="_blank" data-omniture='trackElement|{"trackEvents":"event20,event21","products":";footer:social;;;event21=1,;footer:social;;;event20=1","eVar16":"footer:social","eVar17":"footer:social:"+url,"prop17":"footer:social:instagram:instagram","eVar42":"footer","prop42":"footer","prop67":"social","eVar67":"social","linkName":"footer-social-link","prop68":"instagram","eVar68":"instagram"}'></a>
            </li>

            <!-- PINTEREST -->
            
                

                
                    <li>
                        <a href="https://www.pinterest.com/eentertainment/pins/follow/?guid=WtyoZwkH3aD_-0" class="social-link social-link--pinterest"
                            target="_blank" data-omniture='trackElement|{"trackEvents":"event20,event21","products":";footer:social;;;event21=1,;footer:social;;;event20=1","eVar16":"footer:social","eVar17":"footer:social:"+url,"prop17":"footer:social:pinterest:pinterest","eVar42":"footer","prop42":"footer","prop67":"social","eVar67":"social","linkName":"footer-social-link","prop68":"pinterest","eVar68":"pinterest"}'></a>
                    </li>
                
            


            <!-- TWITTER -->
            <li>
                <a href="https://twitter.com/eonlineasia" class="social-link social-link--twitter" target="_blank"
                    data-omniture='trackElement|{"trackEvents":"event20,event21","products":";footer:social;;;event21=1,;footer:social;;;event20=1","eVar16":"footer:social","eVar17":"footer:social:"+url,"prop17":"footer:social:twitter:twitter","eVar42":"footer","prop42":"footer","prop67":"social","eVar67":"social","linkName":"footer-social-link","prop68":"twitter","eVar68":"twitter"}'></a>
            </li>

            <!-- TUMBLR -->
            
                

                
                    <!-- no tumblr -->
                

                
            

            <!-- SNAPCHAT -->
            
                

                
                    <!-- no snapchat -->
                

                
            

        </ul>
    </div>

    


    
    
    
    
    
    
    
    
        




<ul class="footer__links footer__links--first c-grid l-spacing--md">
  <li>
    <a href="/ap/about" target="_blank" data-omniture='trackElement|{"linkName":"nav:footer:about","products":"eVar16=\"nav\""},"prop17":"eVar16=\"nav\"","eVar17":"eVar16=\"nav\"","eVar16":"frontdoor-modules"}'>
      About Us
    </a>
  </li>

  <li>
    <a href="/ap/faq" target="_blank" data-omniture='trackElement|{"linkName":"nav:footer:faq","products":"eVar16=\"nav\""},"prop17":"eVar16=\"nav\"","eVar17":"eVar16=\"nav\"","eVar16":"frontdoor-modules"}'>
      FAQ
    </a>
  </li>

  <li>
    
      
      
            <a href="https://www.nbcuniversal.com/privacy/cookies" target="_blank" data-hook="cookies-popup"
              data-omniture='trackElement|{"linkName":"nav:footer:cookie-policy","products":"eVar16=\"nav\""},"prop17":"eVar16=\"nav\"","eVar17":"eVar16=\"nav\"","eVar16":"frontdoor-modules"}'>
              Cookie Settings
            </a>
      
    
  </li>

  <li>
    <a href="mailto:Asia@nbcuni.com" target="_blank" data-omniture='trackElement|{"linkName":"nav:footer:Advertise","products":"eVar16=\"nav\""},"prop17":"eVar16=\"nav\"","eVar17":"eVar16=\"nav\"","eVar16":"frontdoor-modules"}'>
      Advertise
    </a>
  </li>
</ul>

<ul class="footer__links footer__links--last c-grid l-spacing--md">
  <li>
    <a href="https://www.eonline.com/ap/shows/peoples_choice_awards" target="_blank">People's Choice</a>
  </li>

  <li>|</li>

  <li>
    <a href="/peoples_choice_awards/faq" target="_blank">
      People's Choice FAQ
    </a>
  </li>
</ul>
    
    


    

    <div class="footer__tagline-wrap">
        <div class="footer__tagline">
            
            <a href="/ap/" class="footer__eonline-logo footer__eonline-logo--ap"
                data-omniture='trackElement|{"linkName":"nav:footer:main","products":"eVar16=\"nav\""},"prop17":"eVar16=\"nav\"","eVar17":"eVar16=\"nav\"","eVar16":"frontdoor-modules"}'></a>
            E! Online - Your source for entertainment news, celebrities, celeb news, and&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;<br>celebrity gossip. Check out the hottest fashion, photos, movies and TV shows!
        </div>
    </div>

    
    

    <div class="footer__bottom footer__bottom--ap">
        
            <a href="https://www.nbcuniversal.com/privacy?brandA=E!_Entertainment&intake=E!_Entertainment" target="_blank" class="footer__bottom-link"
                data-omniture='trackElement|{"linkName":"nav:footer:privacy-policy","products":"eVar16=\"nav\""},"prop17":"eVar16=\"nav\"","eVar17":"eVar16=\"nav\"","eVar16":"frontdoor-modules"}'
                rel="nofollow">
                New Privacy Policy
            </a>
            
                | 
                <a href="/ap/terms"
                target="_blank" class="footer__bottom-link" data-omniture='trackElement|{"linkName":"nav:footer:terms-of-use","products":"eVar16=\"nav\""},"prop17":"eVar16=\"nav\"","eVar17":"eVar16=\"nav\"","eVar16":"frontdoor-modules"}'
                rel="nofollow">
                Terms of Service</a>
            
                
                
                    |
                
            
            
        
        &copy; 2020 E! Entertainment Television, LLC.  A
        Division of NBCUniversal.
        All rights reserved.
        
    </div>

</div> <!-- footer -->
			</div>

			




<div style="display: none;">

	
		
		
				<script type="text/javascript">
		
	

		
			
			
			

				
					s.prop7="eonline.com/news/1119020/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses";
				
					s.prop9="the-masked-singer,tv,top-stories,entertainment,apple-news,celebrities,vg";
				
					s.prop63="news";
				
					s.prop65="top_stories";
				
					s.prop1="news";
				
					s.prop2="news:news";
				
					s.prop3="news:news:top-stories";
				
					s.prop48="news:news:top-stories:articles";
				
					s.prop66="news:news:top-stories:articles";
				
					s.pageName="news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses";
				
					s.events="event42";
				
					s.linkTrackEvents="event42";
				
					s.eVar1="news";
				
					s.prop14="the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses";
				
					s.prop15="articles";
				
					s.prop62="detail";
				
					s.prop19="1119020";
				
					s.prop72="2020-02-03";
				
					s.prop74="vertical-gallery";
				
					s.products=";text-block-photo-with-text;;;event42=1,;text-block-call-to-action;;;event42=1,;text-block-text-only;;;event42=1,;text-block-vertical-gallery;;;event42=1,;text-block-video-only;;;event42=1,";
				
					s.prop58="lauren piester";
				

				
				
				if(typeof wa.page === 'object' && typeof wa.page.advertiser !== 'undefined' && wa.page.advertiser != '') {
				    s.eVar76 = wa.page.advertiser;
				}

			
		

	</script>
	
	
	
		
			
				
				
					
					
						
						
								<script type="text/javascript">
						
					
					/************* DO NOT ALTER ANYTHING BELOW THIS LINE ! **************/
					var s_code=s.t();if(s_code)document.write(s_code)//-->
					</script>
				
			
		
		
	

	
	
		
		
		
		
		
		
		
			
		
	

	<!-- GA (ap) -->
	<script type="text/javascript">
		var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
		document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
	</script>
	
	
		
		
				<script type="text/javascript">
		
	
		var pageTracker = _gat._getTracker("UA-852400-1");
		pageTracker._initData();
		
			pageTracker._trackPageview();
		
	</script>

	
	
		
		
				<script type="text/javascript">
		
	

	
	
		
			const _OPTANON_CAT_2 = true;
		
		
	
		
	</script>

</div>

			

		</div>

		


















	



	
	
	
		
		
	


<!-- Facebook Pixel Code -->
	
		
		
				<script>
		
	
    var fbstarttime = new Date();
		!function(f,b,e,v,n,t,s) {
			if (f.fbq)
				return;
			n = f.fbq = function() {
				n.callMethod?
				n.callMethod.apply(n,arguments):n.queue.push(arguments)
			};
			if (!f._fbq)
				f._fbq = n;
			n.push = n;
			n.loaded =! 0;
			n.version = '2.0';
			n.queue = [];
			t = b.createElement(e);
			t.async =! 0;
			t.src = v;
			s = b.getElementsByTagName(e)[0];
			s.parentNode.insertBefore(t, s);
		}(window, document, 'script', 'https://connect.facebook.net/en_US/fbevents.js');

		fbq('init', '1611373942516879');
		fbq('track', 'PageView');

    var fbendtime = new Date();
	</script>

	
	<noscript>
		<img
			height="1" width="1"
			src="https://www.facebook.com/tr?id=1611373942516879&ev=PageView&noscript=1" />
	</noscript>
<!-- End Facebook Pixel Code -->

<script type=application/ld+json>
	{
		"@context": "http://schema.org", 
		"@type": "WebPage", 
		"@id": "http://m.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", 
		"potentialAction": 
		{ "@type": "ViewAction", "target": "android-app://com.rhythmnewmedia.android.e/http/m.eonline.com/ap/news/1119024/the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses"}
	}
</script>





	
	
	
	
	
	
		
		
		
	
	
	
		
		
				<script type='text/javascript'>
		
	
		var _sf_async_config={};
	
		/** CONFIGURATION START **/
		_sf_async_config.uid = 53221; 
		_sf_async_config.domain = 'eonline.com';
		_sf_async_config.useCanonical = true;
		_sf_async_config.sections = 'news,ap,International';
		_sf_async_config.authors = 'Lauren Piester';
		_sf_async_config.videoPageGroups = true;
		/** CONFIGURATION END **/
	
		(function(){
			function loadChartbeat() {
				window._sf_endpt=(new Date()).getTime();
				var e = document.createElement('script');
				e.setAttribute('language', 'javascript');
				e.setAttribute('type', 'text/javascript');
				e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
				document.body.appendChild(e);
			}

			$(document).ready(function() {
				loadChartbeat();
			});
		})();
	</script>









	
	
	
	
		<script type='text/javascript' src='//s.swiftypecdn.com/cc/2aixc8dsBhfYvfHzhKs5.js'></script>
	
	
	
	
	
	
	
	
	
	









    
    
        
        
        
        
            
        
        
        
        
        
        
        
        
        
        
    

    
    <script type="text/javascript" src="//www.queryly.com/js/queryly.v4.js"></script>
    <script type="text/javascript">
        queryly.init('fcd7be917e454c85', document.querySelectorAll('.eol-outerwrapper,.leaderboard'));
    </script>


<script src="/dist/js/bottom.resources.5.ead06211eda427ae48f0.js"></script>







<div class="js-gdpr-notice gdpr-notice" data-gdpr-isenabled="false">
	<div class="gdpr-notice-wrapper clear">
		<p class="gdpr-notice-text">
			
				
				
				
					We and our partners use cookies on this site to improve our service, perform analytics, personalize advertising, measure advertising performance, and remember website preferences. By using the site, you consent to these cookies. For more information on cookies including how to manage your consent visit our <a href="https://www.nbcuniversal.com/privacy/cookies" target="_blank">Cookie Policy</a>.
				
			
		</p>
		<button class="gdpr-notice-btn js-gdpr-notice-btn">
			
				
				
				
					Continue
				
			
		</button>
	</div>
</div>










	









<div class="js-onee-dialog onee-dialog">
	<div class="onee-dialog-content">
		
		<div class="onee-dialog-header clear">
			<div class="js-onee-flag hidden" data-geoEdition="us">
				<div class="flag-sprite-map new-edition_us"></div>
				<h5>U.S.</h5>
			</div>
			<div class="js-onee-flag hidden" data-geoEdition="ca">
				<div class="flag-sprite-map new-edition_ca"></div>
				<h5>CA</h5>
			</div>
			<div class="js-onee-flag hidden" data-geoEdition="uk">
				<div class="flag-sprite-map new-edition_uk"></div>
				<h5>U.K.</h5>
			</div>
			<div class="js-onee-flag hidden" data-geoEdition="au">
				<div class="flag-sprite-map new-edition_au"></div>
				<h5>AU</h5>
			</div>
			<div class="js-onee-flag hidden" data-geoEdition="ap">
				<div class="flag-sprite-map new-edition_ap"></div>
				<h5>Asia</h5>
			</div>
			<div class="js-onee-flag hidden" data-geoEdition="de">
				<div class="flag-sprite-map new-edition_de"></div>
				<h5>DE</h5>
			</div>
			<div class="js-onee-flag hidden" data-geoEdition="fr">
				<div class="flag-sprite-map new-edition_fr"></div>
				<h5>FR</h5>
			</div>
		</div>

		
			
			
				<div class="js-onee-text hidden" data-geoEdition="us">
					<h3>E! Is Everywhere</h3>
					<p>This content is available customized for our international audience. Would you like to view this in our US edition?</p>
				</div>
				<div class="js-onee-text hidden" data-geoEdition="ca">
					<h3>E! Is Everywhere</h3>
					<p>This content is available customized for our international audience. Would you like to view this in our Canadian edition?</p>
				</div>
				<div class="js-onee-text hidden" data-geoEdition="uk">
					<h3>E! Is Everywhere</h3>
					<p>This content is available customized for our international audience. Would you like to view this in our UK edition?</p>
				</div>
				<div class="js-onee-text hidden" data-geoEdition="au">
					<h3>E! Is Everywhere</h3>
					<p>This content is available customized for our international audience. Would you like to view this in our Australian edition?</p>
				</div>
				<div class="js-onee-text hidden" data-geoEdition="ap">
					<h3>E! Is Everywhere</h3>
					<p>This content is available customized for our international audience. Would you like to view this in our Asia edition?</p>
				</div>
				<div class="js-onee-text hidden" data-geoEdition="de">
					<h3>E! ist &uuml;berall</h3>
					<p>Dieser Inhalt ist f&uuml;r internationale Besucher verf&uuml;gbar. M&ouml;chtest du ihn in der deutschen Version anschauen?</p>
				</div>
				<div class="js-onee-text hidden" data-geoEdition="de-en">
					<h3>E! Is Everywhere</h3>
					<p>This content is available customized for our international audience. Would you like to view this in our German edition?</p>
				</div>
				<div class="js-onee-text hidden" data-geoEdition="fr">
					<h3>E! est partout</h3>
					<p>Une version adapt&eacute;e de ce contenu est disponible pour notre public international. Souhaitez-vous voir &ccedil;a dans notre &eacute;dition fran&ccedil;aise ?</p>
				</div>
				<div class="js-onee-text hidden" data-geoEdition="fr-en">
					<h3>E! Is Everywhere</h3>
					<p>This content is available customized for our international audience. Would you like to view this in our French edition?</p>
				</div>
				<div class="js-onee-text hidden" data-geoEdition="ar">
					<h3>E! está en todos lados</h3>
					<p>Nuestro contenido está disponible y personalizado para nuestra audiencia internacional. ¿Te gustaría verlo en la edición en español?</p>
				</div>
				<div class="js-onee-text hidden" data-geoEdition="co">
					<h3>E! está en todos lados</h3>
					<p>Nuestro contenido está disponible y personalizado para nuestra audiencia internacional. ¿Te gustaría verlo en la edición en español?</p>
				</div>
				<div class="js-onee-text hidden" data-geoEdition="mx">
					<h3>E! está en todos lados</h3>
					<p>Nuestro contenido está disponible y personalizado para nuestra audiencia internacional. ¿Te gustaría verlo en la edición en español?</p>
				</div>
				<div class="js-onee-text hidden" data-geoEdition="ve">
					<h3>E! está en todos lados</h3>
					<p>Nuestro contenido está disponible y personalizado para nuestra audiencia internacional. ¿Te gustaría verlo en la edición en español?</p>
				</div>
			
		
        
        
        
        
        
        
        
        
        
        
        
            
        
            
        
            
		<div class="onee-dialog-btns js-onee-dialog-btns clear">
			<div class="js-onee-btns hidden" data-geoEdition="us">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="ca">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/ca">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="uk">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/uk">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="au">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/au">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="ap">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/ap">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="de">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/de">Ja !</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>Nein, danke.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="de-en">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/de">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="fr">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/fr">Oui!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>Non, merci.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="fr-en">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/fr">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="br">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/br">Sim</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>Não</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="br-en">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/br">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="la">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="http://la.eonline.com">&iexcl;Si!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, gracias.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="la-en">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="http://la.eonline.com">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="ar">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/ar">Si</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="ar-en">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/ar">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="co">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/co">Si</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="co-en">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/co">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="mx">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/mx">Si</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="mx-en">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/mx">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="ve">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/ve">Si</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No</a>
			</div>
			<div class="js-onee-btns hidden" data-geoEdition="ve-en">
				<a class="button js-primary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:yes", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}' data-editionUrl="/ve">Yes!</a>
				<a class="button secondary js-secondary floatLeft" data-omniture='trackElement|{"products":";geo-lightbox;;;event862=1", "events":"event862", "eVar16":"geo-lightbox", "eVar17":"geo-lightbox:news:news:top-stories:articles:1119024:the-masked-singer-begins-again-see-all-the-season-3-contestants-and-the-best-guesses", "prop17":"geo-lightbox:button:no-thanks", "prop42":"lightbox", "eVar42":"lightbox", "linkTrackEvents" : "eVar16,eVar17,prop42,eVar42,prop17,event862"}'>No, Thanks.</a>
			</div>
		</div>
		<div class="onee-dialog-footer">
			
				
				
					<a href="#" class="js-onee-dialog-translate hidden" data-geoEdition="de" data-translateToEdition="de-en">Translate to English</a>
					<a href="#" class="js-onee-dialog-translate hidden" data-geoEdition="fr" data-translateToEdition="fr-en">Translate to English</a>
					<br>
				
			
			<a href="/de/impressum" target="_blank" class="js-onee-dialog-impressum hidden" data-geoEdition="de">Impressum</a>
		</div>
	</div>
</div>





	<script type="text/javascript">_satellite.pageBottom();</script>


		








	

	

	

	

	

	








	<script type="text/javascript">
		window._taboola = window._taboola || [];
		_taboola.push({flush: true});
	</script>


	</body>
</html>
